0
$\begingroup$

I'm trying to render models and composite them into an existing image with known depth. However, one of model I use has hair made with a lot of semitransparent strands. When I render it with Cycles, depth values for some pixel on the hair have depth as if nothing is there:

enter image description here

That causes problems with compositing: background it showing where hair should be (using "Z Combine" node). I've tried LuxRenderer, and everything works as expected there. Is there a way to get proper depth values in Cycles? I've tried increasing transparent bounce count (both min and max). It still renders noisy depth (and perf tanks, which is a huge problem).

(exr render: https://yadi.sk/d/unyMODQ5-atJEw)

$\endgroup$
1
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Oct 13, 2021 at 22:42

1 Answer 1

0
$\begingroup$

There's Alpha Threshold setting that controls whether semitransparent contribute to Depth, Mist, UV or some other passes. Setting in to 0 makes it so every hair strand no contributes to depth. That may not be a universal solution, but it worked well enough for case described in the question.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .