0
$\begingroup$

I'm attempting to bake a normal map from a sculpt. Some of the UV islands intentionally overlap for the purpose of mirroring certain details and conserving space.

However, the normal map doesn't look quite right:

The character model, with the baked normal map.

Back view of the character model with the normal map.

If I look closely enough, I can even find various body parts in places they shouldn't be.

A compilation of the stuff seen in the normal map.

I feel like I've exhausted everything I could've done to get this to look right. So far, I've:

  • Adjusted the extrusion
  • Adjusted the max ray distance
  • Enabled "Cage" under "Selected to Active"
  • Lowered the margin under "Output"
  • Separated the overlapping tiles
  • Set the rendering device to "GPU Compute" (which wasn't enabled in preferences, oops)
  • Upgraded from Blender 2.91 to 2.93 without importing settings
  • Applied a subdivision surface and a shrinkwrap modifier to my low-res model in order to make it align even more with the high-res model

Each of these steps have either slightly altered the results or made no difference at all. I've even created a test project in an attempt to replicate the issue, only to end up with a clean normal map.

The test project, with a successfully baked normal map.

Baking normal maps for character models has always been a huge struggle I've wanted to overcome. I've been trying to figure this out for a while, and while there's been some improvement, I still can't get it quite right. I just feel like I've been missing something really obvious.

I can DM the project files by request. Thanks you so much in advance!

$\endgroup$
4
  • $\begingroup$ I dont see you mentioning recalculating your normals, did you try it? Alt+N and recalculate, this may be due to normals issue or shading(if not I hope someone will find answer $\endgroup$
    – MikoCG
    Oct 13, 2021 at 8:03
  • $\begingroup$ hello maybe share your file if you want us to try? $\endgroup$
    – moonboots
    Oct 13, 2021 at 8:13
  • $\begingroup$ @MikoCG I've recalculated my normals and averaged my face area! Unfortunately, that didn't change the output. $\endgroup$
    – MEATTAIL
    Oct 13, 2021 at 23:51
  • $\begingroup$ @moonboots I can't seem to find a way to DM you, so here's the link to the project! $\endgroup$
    – MEATTAIL
    Oct 14, 2021 at 0:16

1 Answer 1

2
$\begingroup$

Though you said you have done this, I still believe adjusting extrusion to something like ~0.02m would fix the issue (there is a clear projection of one leg on the other), and also check face orientations.

$\endgroup$
2
  • $\begingroup$ Setting the extrusion to 0.02m helped a ton! Here's what the front view looks like now, and here's the rear view. I have backface culling enabled in viewport shading, but I recalculated the normals and averaged the face area just in case. (It didn't change the output though.) $\endgroup$
    – MEATTAIL
    Oct 14, 2021 at 0:03
  • $\begingroup$ I'm accepting this as the answer, but I just want to mention that I also touched up the normal map in texture paint mode! It seems to be virtually impossible to bake a perfect normal map in any program, but an extrusion of 0.02 m is optimal. Thank you! $\endgroup$
    – MEATTAIL
    Oct 15, 2021 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .