1
$\begingroup$

I have two objects which are copies of one another. On the first one, I have manually marked the seams and unwrapped it, with the idea of copying this data to the second one. Example shown below:

the two objects in question

I have selected both of them, clicked Object>Link/Transfer Data>Copy UV maps and have confirmed both objects have identical unwraps as shown below:

UV unwrap after copy

However, when I apply the same material to the second object, it looks stretched, like below:

Material on second object

I couldn't find any meaningful difference between the two objects, other than the seam data seems to be missing from the second one. I have tried copying the mesh data by using the Object>Link/Transfer Data>Transfer Mesh Data and selecting the seams option, but it does seem to copy them incorrectly no matter what method I choose, making proper unwrapping impossible. I have verified that the objects have the exact same number of vertices, edges, faces and triangles, so I don't think that is the problem.

How can I properly apply the material on the second object without manually tracing the seams on it?

$\endgroup$
2
  • $\begingroup$ Good question, had the same issue years ago. Do you mind sharing a blend to compare the two? $\endgroup$
    – brockmann
    Oct 13 at 11:14
  • $\begingroup$ I've uploaded it and have edited the question to include it. $\endgroup$ Oct 14 at 19:52
3
$\begingroup$

Looks identical, but... UV on the second one is a mess-up!

enter image description here

Why does it happen? Because objects are not identical. And even after I sort vertexes by Z axis, it still not perfect:

enter image description here

How to fix that? Use Data transfer modifier. Before using it, I decided to reset origin by Context menu (W or RMB) ⇾ Set origin ⇾ Origin to geometry. This is a setting with best results:

enter image description here

$\endgroup$
3
  • $\begingroup$ I've sorted the vertices by the Z axis (went to mesh-Sort elements-View Z axis), brought the origin to the object's geometry and applied the modifier exactly as you have shown in the screenshot, but unforunately the object looks the same. Do you recall if you did anything else to the elements? $\endgroup$ Oct 15 at 1:07
  • $\begingroup$ You have not uncheck a little button near the object name in the "source" field $\endgroup$
    – Crantisz
    Oct 15 at 6:36
  • $\begingroup$ Wow. It did work. Thank you so much. $\endgroup$ Oct 19 at 2:57
1
$\begingroup$

The models are not the same so the copy did not work. You can check it like this: select some faces on the original and see where they unwrapped to.

original

And compare with the same faces selected on the copy.

copy

You can see these faces are scattered at random over the UVMap. It's as if all the faces were scrambled; the shape of the UVMap is the same, but which face goes where is all mixed up.

It seems like in addition to having the same number of verts, tris, etc. they need to go in the same order for data copy to work. Because if you find the poly with index 11, say, in the copy, it's unwrapped to the same spot as the poly with index 11 in the original (compare with the first picture).

poly 11 in the copy

(See here for how to see indices.)

$\endgroup$
1
  • 1
    $\begingroup$ Is there any way to order the faces the same as the first object? $\endgroup$ Oct 15 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.