2
$\begingroup$

I'm coloring a character model in texture paint mode. There are two images: One for the base color and one for the secondary colors. I'm treating these images as if they were layers with a MixRGB node.

A view of the texture's nodes in the shader editor.

Unfortunately, when I attempt to color the hair dark brown on the secondary image, it doesn't appear in the 3D viewport. White, however, is completely visible.

The view from the 3D viewport.

The colors on the secondary image appear properly in the image editor and in the 3D viewport with the mix factor set to 1.

The second image in the image editor.

The second image, as seen in the 3D viewport with a mix factor of 1.

I've been using Subtstance Painter for about a year, but I'm trying to complete this project entirely within Blender in order to througly learn my way around the program.

I've tried using the Layer Painter extension, which is great, but there doesn't seem to be any way to select which layer I'm painting on when attempting to paint directly in the image editor. Attempting to paint in the image editor with the extension enabled has yielded crashes.

How do I get two images to stack on top of each other in the node editor?

Thanks in advance!

$\endgroup$
5
  • $\begingroup$ did you try to use the other blend modes in the mix shader node? [1]: i.stack.imgur.com/fjmZh.png $\endgroup$
    – Chris
    Oct 11 '21 at 5:42
  • $\begingroup$ @Chris Yes! I thought "Overlay" was the most obvious solution but it doesn't appear to make much of a difference: i.imgur.com/8jvvjIR.png $\endgroup$
    – MEATTAIL
    Oct 11 '21 at 5:44
  • $\begingroup$ can you provide us your two images so we can try on our own? $\endgroup$
    – Chris
    Oct 11 '21 at 5:49
  • $\begingroup$ @Chris Here you go! imgur.com/a/oGAX66K $\endgroup$
    – MEATTAIL
    Oct 11 '21 at 5:57
  • $\begingroup$ did they have transparent parts? $\endgroup$
    – Chris
    Oct 11 '21 at 6:03
5
$\begingroup$

I hope/think you want to have this:

enter image description here

so you just plug the alpha value in the mix node.

$\endgroup$
2
  • $\begingroup$ That worked! Thank you so much. i.imgur.com/RrBIP0v.png $\endgroup$
    – MEATTAIL
    Oct 11 '21 at 6:22
  • $\begingroup$ You are welcome ‼️ $\endgroup$
    – Chris
    Oct 11 '21 at 7:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.