0
$\begingroup$

I'm doing some modding on an older game, and mesh import\export scripts for it (https://www.nexusmods.com/dragonage/mods/268) were written for 2.49, and unfortunately were never updated for newer versions, so i'm stuck with it.

The problem is, Blender won't execute the scripts, complaining about the line of code: import BlenderUI and the console says, "ImportError: No module named BlenderUI". BlenderUI is a module that comes with the script. The module is a compiled python script .pyc. According to older Blender docs, it should load modules automatically if they are located in the same folder as the .blend file you're working on. Well, they are all in the same folder, and nothing.

Now the scripts definitely worked for me before, and they're not the only ones that have issues. I have yet another set of scripts for a different game, and they also don't work because the included modules won't load, and they also worked in the past. That was when i was running Win7 though, nowadays i'm on Win10, so maybe it's os related somehow?

I have Python 2.6.2 installed right now, i tried installing a few other versions, 64bit\32bit, but nothing seems to change. I noticed that the script does loads Python's modules, so i tried dropping .pyc files in Python26\Lib\site-packages\ folder, hoping that Blender will find them there, and i think it did, but then it just complains that it can't find other script related files, which are still present in that same older.

Thought that maybe Blender doesn't have access to the folder, tried running it as admin, tried compatibility modes with older Windows versions, no luck. Does anyone have an idea what might be the issue? Again, both scripts i tried used to work before, so i don't think that it's just because they're buggy or anything.

$\endgroup$
2
  • $\begingroup$ Blender has changed a lot since 2.49. I would suggest you try to find and install that version, import your assets, save to a blend, and then open in modern blender. The alternative is to find a Python programmer to update your import module scripts. $\endgroup$
    – Ron Jensen
    Commented Oct 10, 2021 at 23:32
  • $\begingroup$ downloads are here $\endgroup$ Commented Oct 10, 2021 at 23:42

1 Answer 1

0
$\begingroup$

The problem was that Blender looks for BlenderUI only in the "current" folder. The easiest way to fix this is to run console, cd into DragonBlender directory and run blender from there. Adding DragonBlender folder to PATH also should do the trick, in theory.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .