1
$\begingroup$

I am new to Blender and having some issues following tutorials along where the mesh is assigned to bones. I have created a mesh and an armature. Bones are working as expected. At this point I am supposed to be able to parent the mesh to the armature by selecting the mesh, shift selecting the armature and then Ctrl-P, Parent with empty groups. Then I should select portions of the mesh and assign to vertex groups. One problem is I am unsure of the steps required to do this. Once I get the mesh portion selected (in Edit mode) I cannot find where the vertex groups are to assign. I may be in the wrong mode but the tutorials get a little vague (to me) at this point. Also, when I eventually can find the vertex groups it seems they are not all there. When I Parent with empty groups, should it create vertex groups for each bone?

I need a simple straight forward tutorial on this process.

Thank you

$\endgroup$
4
  • $\begingroup$ Yes in the Object Data panel > Vertex Groups, you should see the list of vertex groups the parentage has created, then you select the vertices you want in the mesh, select the vertex group you want in the list, and press on the Assign button $\endgroup$
    – moonboots
    Oct 10, 2021 at 12:16
  • $\begingroup$ Is there a particular mode I should be in? I seem to only be able to select the mesh when in Edit mode, but then the vertex groups are not available. I'm so confused as the tutorials make it seem so simple. And as I said before, it appears that not all the vertex groups are being created when I parent. Unless I am misunderstanding this altogether. $\endgroup$
    – Toroso
    Oct 10, 2021 at 12:49
  • $\begingroup$ maybe share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Oct 10, 2021 at 13:23
  • $\begingroup$ Hopefully this works, first time trying this. pasteall.org/blend/af8f805ea59848379c635d360a8335ff $\endgroup$
    – Toroso
    Oct 10, 2021 at 15:08

1 Answer 1

1
$\begingroup$

You must have made a mistake at some point. First click on the Vertex Groups dropdown menu and Delete All Groups:

enter image description here

Also delete the Armature modifier in the Modifiers panel. Select the armature and in Edit mode, select the controller and target bones, go in the Bone panel and disable their Deform option.

Now parent the robot object again with the With Empty Groups option (not Automatic Weight which is made for organic things). Select the robot object, switch to Edit mode, select the left foot for example, go into the Vertex Groups list, select Foot.L, press Assign, and so on for the other parts:

enter image description here

$\endgroup$
9
  • $\begingroup$ Success!!! Thank you so much. Now, any idea what I did wrong so I can avoid it in the future? Also, the Foot.R vertex group was not created and I had to manually create it. Is this a bug in Parenting with Empty Groups? Where does the Armature modifier come from? Is that created when the parenting is performed? Thank you again for your help. $\endgroup$
    – Toroso
    Oct 10, 2021 at 15:38
  • $\begingroup$ mmh Foot.R should be here, when you parent With Empty Groups it will create as many Vertex Groups as you have bones (as long as their Deform option is enabled) and the vertex group will share the exact same name as the bones. It's a way of parenting that is ideal for machines and robots as it doesn't assign any vertex to any group, it let you do it. $\endgroup$
    – moonboots
    Oct 10, 2021 at 15:45
  • $\begingroup$ The modifier will automatically appear as soon as you parent with one of the Armature Deform options (so With Empty Groups or With Automatic Weight). You didn't have to delete the previous modifier as it had no armature selected but it was just in order to make it clean. $\endgroup$
    – moonboots
    Oct 10, 2021 at 15:45
  • $\begingroup$ Well, almost success. I see now that the vertex group for Foot.R, the one I had to create, is not working. But I'm further along than before! $\endgroup$
    – Toroso
    Oct 10, 2021 at 15:57
  • $\begingroup$ make sure that you have not disabled its Deform option by mistake. Actually you don't really have to disable the Deform option for these bones when parenting WIth Empty Groups but it was just a way to explain how it works $\endgroup$
    – moonboots
    Oct 10, 2021 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .