0
$\begingroup$

Recently I came back to blender after a while. I started by rigging my model and it didn't work at all. I've set up a rig and parented it with automatic weights and the mesh would not move in pose mode. I wasn't sure if there was a problem with a model so I made simple model of subdivaded cube and 4 bones. I parented it again and it still did not work. I've been searching for a solution for a few days but so far no luck. I've found that there is no armature modifier after parenting but I'm not sure if that is the source of the problem or what I should do about it. Any ideas?

https://pasteall.org/blend/e60a826608a74fe0b0d6f9841127fa63

$\endgroup$
2
  • $\begingroup$ Hello, please share your object + armature so that we can give a try: pasteall.org/blend $\endgroup$
    – moonboots
    Oct 9, 2021 at 12:29
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Oct 9, 2021 at 13:48

1 Answer 1

1
$\begingroup$

The correct and working procedure is to select the object, shift select the armature, Ctrl P > with automatic weights.

Check if after parenting you get a yellow error report on the bottom of the window (Bone heat fail).

Check if your bones have their "deform" option ticked in pose mode.

The automatic parenting is the same as doing theese things:

Parent the mesh to the armature in object mode. Add an armature modifier to the mesh, targeting the armature. Create as many vertex groups as the number of deforming bones. Give them the same name as the bones and some weight based on the location of vertices and bones.

If still in trouble, please upload your file.

$\endgroup$
4
  • $\begingroup$ Sorry for the late reply and thank you for your suggestions. I did and checked what you said but still doesn't work. I've added the link to the file if you are interested in checking it out. $\endgroup$ Oct 13, 2021 at 14:28
  • $\begingroup$ The problem is only the order of selecting: Blender can have many objects selected, and one (last selected) active. If you perform the selection on the outliner the order is reversed, and the first selected is the active one. The selection is right when you have (both in the viewport and the outliner) the mesh orangy (selected) and the armature yellowish (active). Before parenting, select the armature and press Alt P (remove parenting): this is necessary for avoiding a parenting loop (mesh parent of the armature parent to the mesh ....). $\endgroup$ Oct 13, 2021 at 16:38
  • $\begingroup$ If you need to reverse the selection order, hold shift and click on the desired parent (the armature) multiple times until you get the correct color (yellowish). Then Ctrl P > with automatic weights will do the job as expected. $\endgroup$ Oct 13, 2021 at 16:39
  • $\begingroup$ Thank you very much, I haven't noticed this at all. It works like a charm right now. Again thank you very much, now i can move on with my project. $\endgroup$ Oct 15, 2021 at 9:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .