2
$\begingroup$

I am not quite sure how, but I have managed to set the object normals to be the same as the global normals:

Axes in 'Global' mode: enter image description here This is expected.

Axes in 'Normal' mode: enter image description here I would expect one of the axes to run parallel to the length of the object.

I need the axes to be back to where they were. I understand that this cannot be done for arbitrary shapes, but in this case, the object is symmetrical around that point only along the normal axes that I want, so I would expect there to be a way to snap the axes back.

I certainly had the axes in the correct place at some point, I'm not sure what I did to break them.

$\endgroup$
3
  • $\begingroup$ some combination of rotating the object in edit mode and/or applying rotation in object mode, possibly $\endgroup$ Oct 6 '21 at 22:46
  • $\begingroup$ @MartyFouts Yeah, I'm pretty sure that's what caused it. How do I fix it? ;) $\endgroup$
    – Alex
    Oct 6 '21 at 22:50
  • $\begingroup$ blender.stackexchange.com/questions/170977/… by hand but I don't know a way to automatically make them reset $\endgroup$ Oct 6 '21 at 22:56
1
$\begingroup$

You must have applied the rotation of your object (its local orientation is now aligned with the global orientation). If you want to realign the local orientation with the orientation of your object faces, you can do it this way:

Select a face of your object in Edit mode and in the Transform Orientations panel click on the + button to create a custom orientation that is aligned with this face normal:

enter image description here

In the Options panel, enable Only Affects > Origin in order to be able to move and rotate the object's origin:

enter image description here

Go into the header menu > Object > Transform > Align to Transform Orientation in order to align the origin's orientation with the custom orientation:

enter image description here

You can deactivate the Only Affects > Origin option and go back to Global orientation in the Transform Orientations panel.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.