5
$\begingroup$

I have problem with compositor.

It doesn't show result in output render until I replug Image into Composite node.

I am rendering 2 layers, but it show only first layer, without anything modified, until I unplug and plug back into Image slot in Composite node. Then it shows correctly.

NODE SETUP: enter image description here enter image description here

EDIT:

Result doesn't show in render output. In Viewer it is visible.

EDIT 2:

Here is the blend file. Sorry for wrong file.

$\endgroup$
  • $\begingroup$ We need to see your node setup to be able to help any $\endgroup$ – VRM Jan 30 '15 at 12:13
  • 2
    $\begingroup$ I've had similar behavior. Rendering with F12 seems to work for me as well to 'reboot' the compositor output. I'm new here so I figure I'm missing something. Can't wait to see a good answer. $\endgroup$ – Chuck Jan 30 '15 at 13:56
  • 1
    $\begingroup$ If you don't hit F12 there will be no information for the compositor to work with. $\endgroup$ – cegaton Jan 30 '15 at 15:02
  • $\begingroup$ uhhh. I don't understand. the composite never shows until everything is plugged in. It's like saying "this thing doesn't work when it's off". Did I misunderstand? $\endgroup$ – Scalia Jan 30 '15 at 15:27
  • 1
    $\begingroup$ in the bottom of the render tab there is "Post processing" contains "compositing" option which should be checked $\endgroup$ – Chebhou Feb 2 '15 at 12:52
6
$\begingroup$

To enable compositing go to Post processing in the Render tab of the Properties Panel and:

  • check the Compositing option
  • uncheck the Sequencer option

this will process the render result through the compositing pipeline if the compositing nodes are enabled.

Compositing

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.