1
$\begingroup$

So I've got two groups of assets in my Blender file:

  1. An animation with associated objects
  2. A set of static objects that will be attached in Unreal

I'm exporting these to FBX in two separate groups, and importing them as such, so I can keep the animation together and move the statics separately.

The animation gets imported to UE4 with a 100x scale modifier. I have absolutely no idea where that's coming from, I can't seem to edit it, but it actually results in a correctly-sized object so whatever.

The statics, however, don't get that 100x modifier so they're tiny relative to the animated structure, and I cannot for the life of me figure out how to increase their scale.

I've tried all of the following, none of which has any effect on the scale of the statics:

  1. Applying scale before export
  2. Including a scale modifier in the "Transform" section during FBX export
  3. Toggling "Apply Unit" on and off (I don't even remember what it was originally, I've tried both ways)
  4. Switching "Apply Scalings" from "All Local" to "FBX All"
  5. Setting "Import Uniform Scale" in UE4 to 100 during import
  6. Enabling and disabling "Convert Scene Unit" in UE4

Absolutely none of those things did anything and I feel like I'm losing my mind here.

This is my export and import settings as they currently are, though like I said I've tried all sorts of random things here:

enter image description here

enter image description here

$\endgroup$

2 Answers 2

0
$\begingroup$

In the editor select all and press Ctrl + A Apply > Scale

$\endgroup$
1
  • $\begingroup$ Hi, thanks for the post. This site is not a regular forum, answers should be substantial, stand on their own, and thoroughly explain the solution and required steps. One liners and short tips rarely make for a good answer. If you can edit your post and provide some more details about the procedure and how it works, perhaps add a few images illustrating some steps and final result. See How to write a good answer?, otherwise it may be converted to a comment. $\endgroup$ Dec 1, 2022 at 20:32
0
$\begingroup$

SOLUTION! May 17th 2023:
"How to solve the issue of blender exported skeletal meshes importing at tiny size"
(Using Blender Version: 3.5.1, Unreal Editor Version: 5.1.1-23901901+++UE5+Release-5.1)

  1. In Blender, in the Scene Properties Panel, ensure the following unit settings are implemented: enter image description here

    • Unit System: Metric
    • Unit Scale: 0.01
    • Length: Meters
  2. In the blender FBX exporter, ensure the following nondefault Export Settings:

    • Transform > Scale: 1.0
    • Add Leaf Bones: False (Untick)
    • Limit To: Selected objects (Select your mesh and then your armature before exporting, nothing else)

    Here are all my export settings:

    enter image description here enter image description here

  3. In the unreal engine FBX Importer, ensure the following nondefault settings:

    • Import Animations: True
    • Use T0 as ref pose: True
    • Transform > Import Uniform Scale: 100.0

    enter image description here enter image description here

This should import your model perfectly, with its animations and armature, all at the normal size you expect them to be.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .