0
$\begingroup$

Whenever I add an object in Blender, add the Quick Explosion effect, and check the "fade" checkbutton, for some reason the object (in my example, a cube) goes semi-transparent.

Cube without quick explosion:

enter image description here

Cube with quick explosion:

enter image description here

Cube with quick explosion and fade:

enter image description here

Could anyone tell me why this is happening and how to prevent it? This is in Blender 2.83.5 and it only occurs when using Eevee, not Cycles.

$\endgroup$
4
  • $\begingroup$ The reason is that the quick explosion is adding and animating a transparency node in your material. Take a look at it in the shader editor and you can see the addition. $\endgroup$ Oct 1, 2021 at 23:39
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Oct 1, 2021 at 23:39
  • $\begingroup$ @MartyFouts Sorry, that doesn't help. I tried deleting the transparent node and it did nothing: the semi-transparency is still there. $\endgroup$ Oct 1, 2021 at 23:50
  • 1
    $\begingroup$ please add your blend file to your question (How to add a blend file) $\endgroup$ Oct 1, 2021 at 23:55

3 Answers 3

1
$\begingroup$

I just ran into this issue and Marty Fouts is correct. You have to remove the transparency node, and then remove the mix shader node it uses to blend into the rest of the material. To do this, go to the Shading Tab and unplug it the mix shader node from the principle BSDF node, or whichever is your main texture/color node. Then plug that node into the material output node. This should remove the transparency. Nodes After Transparency is Separated

$\endgroup$
1
  • $\begingroup$ I am glad that worked for you! However, when I reproduced the problem (I'm now in 2.9) the direction you described didn't work for me. I tried @Daemeon's answer again, but it just disables the fade altogether. However, I also tried turning off the Show Backface option in the Material Properties tab and that seemed to work. $\endgroup$ Dec 12, 2023 at 14:40
0
$\begingroup$

@William's answer inspired me to try fixing the problem again (the path described didn't seem to work for me). I discovered that by disabling the Show Backface option in the Material Properties tab fixes the problem without disabling the fade, like in @Daemeon's answer.

Fixed the problem

$\endgroup$
-1
$\begingroup$

Go to Material properties setting and set the Blend Mode to Opaque. Shadow mode also.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .