0
$\begingroup$

I was trying to model a character (not original, modelling from an already existing character for practice). I did the unwrapping, and texture painted, saved the images also. Mapped those images to the material. This is how the model looked after all the work.

enter image description here

But when I rendered the image, the output was this

enter image description here

In both EEVEE and Cycles, this was the output. I checked the face orientation, they was no issue with them. Since I can't see this in viewport I'm not able to understand how to fix this.

This happening for the textured painted surface only, the clothes are not texture painted.

$\endgroup$
1
  • $\begingroup$ My guess is that you have original mesh hidden in hierarchy but visible in render... unhide all objects with Alt+H, is there your original model clipping through your model? $\endgroup$
    – MikoCG
    Oct 1 at 9:09
2
$\begingroup$

To expand my comment:

Is there an object in your hierarchy that is hidden in the viewport (closed eye) but visible in the render? (white camera icon)

enter image description here

If this is your case, please uncheck the camera button so that your object will not be visible in the final render. Always keep in mind that you can hide from the viewport and render separately.

If this is not the case, please show me more info or share your file with us

$\endgroup$
1
  • 1
    $\begingroup$ It worked!!!:D There was a mesh that was hidden. Thank you!!!! Thank you so much! $\endgroup$
    – greenbeans
    Oct 1 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.