0
$\begingroup$

I've been attempting to simulate cloth in Blender for a character model.

The standalone clothing, showing the seams.

When I play the animation, the clothes will seemingly scramble all over the character.

The clothes jittering over the character model.

I've tried isolating the issue with a simple cross to see if the character model was causing the issue, but the results appeared to be the same.

The results being replicated on a cross.

The clothes simply don't sit still. Also, the seams don't fully connect. Here are the cloth settings, for good measure:

A screenshot of the cloth settings.

Also, when pressing the play button, it often takes about a minute to complete the first 48 frame loop. Is this normal?

Thank you so much!

Update, 09/30/21: I realized that my normals weren't alligned properly, but I'm still having the same issue!

Update, 10/01/21: I set my collision distances to 0.001 m, and got better results! unfortunately, there's still some jittering:

The clothing still jitters.

$\endgroup$
5
  • 2
    $\begingroup$ I guess self-collusion distance more than distance between vertexes. $\endgroup$
    – Crantisz
    Oct 1 at 7:13
  • 2
    $\begingroup$ As @Crantisz says, it is either distance in object collision or distance in self-collision that is causing this problem... Try to set it to lower value like 0.001 for example. Btw are you using 2 sided cloth? I would recommend to use only simple plain and give it mass later with solidify $\endgroup$
    – MikoCG
    Oct 1 at 7:22
  • $\begingroup$ @MikoCG I set the collission values to 0.001, and it helped a lot! i.imgur.com/Fn4Q88J.png However, I still see some jittering present: i.imgur.com/zEwDNpm.gif What do you mean by two sided cloth? Where can I change this setting? $\endgroup$
    – MEATTAIL
    Oct 2 at 5:52
  • 1
    $\begingroup$ It seems cloth goes through the mesh. Adding quality steps and/or decrease swearing speed should help. And 0.001 maybe to low, try to get balance $\endgroup$
    – Crantisz
    Oct 2 at 5:58
  • $\begingroup$ @Crantisz i set the distances to 0.005m and the impulse dampening to 50 and it helped a ton! i am still experiencing some jittering but it's very minor: i.imgur.com/unjd5tb.gif $\endgroup$
    – MEATTAIL
    Oct 3 at 2:31
1
$\begingroup$

Here's how I fixed this:

  • Set the object collision distance to 0.015 m
  • Set the self collision distance to 0.001m
  • Skipped to the last frame in the animation and applied the cloth modifier
  • Edited the clothing accordingly
  • Enabled cloth physics again

The cloth physics in action.

Lowering the clollision distances is what made the biggest difference. Although there was still some jittering, it was quickly fixed after applying the cloth modifier, touching up the clothing, and reapplying the cloth modifier.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.