1
$\begingroup$

I'm aware a similar question exists. There is no proper answer and I'll elaborate why I ask this again.

I'd like to show only the upper body of my character, so when I weight paint the arm, I won't accidentally paint the leg or other parts.

I tried the following methods:

  1. Mask modifier. It's horrible because the hidden part still gets painted. You can paint the upperbody than find the lower body's weight is all over the place. And there is absolutely no visual clue telling you're messed up.

  2. Select unwanted vertex, H to hide them in Edit mode. It simply doesn't work at all. Weight paint mode doesn't respect the visiblilty set in Edit mode. (the answer posted on the other question)

  3. Paint Mask of weight paint mode. It kind of separates the unwanted part, which is good, but in this mode I can no longer select bone. With Paint Mask disabled, ⌃ Ctrl+LMB LMB selects a bone. But with Paint Mask enabled, ⌃ Ctrl+LMB LMB selects a face (or vertex).

There must be a more proper way to do this, without sacrificing the ability to select bones, right? I just can't figure it out.

$\endgroup$
5
  • $\begingroup$ Method 2 requires an additional pair of steps. Once you've hidden the vertices, go into weight paint mode, switch to vertex select and then hit A. the vertices hidden in edit mode should now be hidden and the weight paint shouldn't effect them. $\endgroup$ Oct 1, 2021 at 0:29
  • $\begingroup$ @MartyFouts well then it becomes Method 3 and I can't select bones anymore... $\endgroup$ Oct 1, 2021 at 0:54
  • $\begingroup$ toggle mask. make selection. toggle mask. $\endgroup$ Oct 1, 2021 at 6:12
  • $\begingroup$ maybe Alt B to limit borders would help? $\endgroup$
    – moonboots
    Oct 1, 2021 at 12:06
  • 1
    $\begingroup$ Thank you both! Alt+B works quite well for me. I also set a shortcut to toggle Paint Mask just in case. $\endgroup$ Oct 1, 2021 at 21:23

0

You must log in to answer this question.

Browse other questions tagged .