0
$\begingroup$

I'm trying to model a pill bottle top but I'm experiencing really slow performance when using the subdivision modifier. I have a Legion 5P with AMD Ryzen 7 4800H, Nvidia RTX2060 and 32GB RAM running Blender 2.93.4. I created a cylinder with 144 vertices, then extruded and scaled the alternate faces as shown. Adding a subdivision modifier to this object is super slow, and if I then try to add an edge loop around the circumference to square up the edges, my whole system grinds to a halt. I'm quite new to Blender and no expert when it comes to tech. Viewport level for the sub-D modifier is set to 1 and the System Preferences are configured to use the GPU. Is there anything else I might have overlooked or is this normal behaviour when trying to apply a sub-D modifier to an object with this amount of detail? pill bottle top

system preferences

desired result

result-with-edge-loops

$\endgroup$
3
  • 2
    $\begingroup$ A low-poly model with a level 1 Subdivision Surface modifier should not cause lag on your computer. I wonder you want to have a Subdivision Surface on this model. It won't get smoother, does it? I've just tried the same and was surprised that Blender indeed froze for several seconds & the output looks weird (i.stack.imgur.com/RuSJB.jpg). The reason is the big Ngons on top and bottom. But yours look good and I'm not sure if we did the same? Maybe post a full screenshot? What's the yellow shading? Is this in edit mode? How many verts do you have with the modifier? Which mode has it? $\endgroup$
    – Blunder
    Sep 30, 2021 at 18:32
  • $\begingroup$ Hey Blunder, Thanks for the reply. Yeah mine looked the same as yours after the first sub-d. I wanted to add a couple more edge loops around the circumference of the object and slide them up and down to tighten up the corners. This then starts to look more like a pill bottle top. I wanted to do this visually hence why I tried to add the loops with the sub-d on, but no chance - Blender dies ! The yellow shading is just one of the built in matcaps - my preferred look for editing. $\endgroup$
    – Marcus
    Oct 1, 2021 at 11:39
  • $\begingroup$ My object has 576 verts. I figured out if you disable Use Limit Surface in the sub-d settings it works much better, but you still have to wait ages for the first sud-b to be applied before you can disable this, which is really annoying, but it got me there. I don't fully understand what Use Limit Surface actually does. PS : How can I post additional images to show you the end result? Do I have to add them to my original post? $\endgroup$
    – Marcus
    Oct 1, 2021 at 11:39

1 Answer 1

2
$\begingroup$

Have you tried to delete the cap at the top and bottom (the fan and the big ngon) and replace it with a grid fill (Ctrl+F)?

Replaced the cap with a grid fill: topology with grid

With a Subsurface Division modifier (level 1): model with sub-d modifier

$\endgroup$
1
  • $\begingroup$ Thanks ! This worked great, and no need to disable the Use Limit Surface either with this approach. Good call. Thank you again. $\endgroup$
    – Marcus
    Oct 16, 2021 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .