1
$\begingroup$

I have two animations in my current project. I used the the graph editor for the second animation (frame 25 to 48) and can no longer insert keyframes behind the last frame of the second animation. Or rather, when I create a pose, mark all bones, and insert a new keyframe, it does insert a new keyframe, however the pose is instantly changed to the last keyframe of the second animation when I switch the current keyframe (I have also tried to insert a visual keyframe, without any changing result).

(Not sure how I can embed a video, so I uploaded it here): YouTube Video

In the video you can also see that the graph editor does change, but the animation doesn't.

I am not sure if this has something to do with the issue, but when I tried to identify the error I saw these weird keyframes which I can't remove. They don't seem to do anything (They were inside the actual keyframes and I discovered them when moving the keyframes) Weird keyframes are highlighted yellow

I suppose I did something wrong with the graph editor but don't know what. The only thing I did inside the graph editor was to change the curve of the y axis of the feet in the walking animation.

EDIT: The Blender file here.

$\endgroup$

2 Answers 2

2
$\begingroup$

The graph editor doesn't have anything related: the problem lies in the fact that you're editing the action as a NLA strip. The strip ends at 48, so every edit you make after that frame is stored in the action but it's not read by the rig because NLA tells it to stop evaluating that strip at frame 48.

To solve open a NonLinear Animation Window and untick the "Armature" box, to disable NLA stack.

$\endgroup$
1
  • $\begingroup$ Thank you very much this solved my issue. $\endgroup$
    – Racid
    Sep 30, 2021 at 16:35
0
$\begingroup$

Have you examined the options in Blender>Preferences>Animation: "Only insert needed" (untick) "Only Insert Available" (untick)

$\endgroup$
1
  • $\begingroup$ Both of them are unticked. Ticking and unticking them didn't change anything. $\endgroup$
    – Racid
    Sep 29, 2021 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.