0
$\begingroup$

I know that I can hide light objects by: "Viewport Overlays / Objects / Extras", but it is hiding camera objects too! :(

In my project I have many lights, and now, when I'm done with lighting of the scene, I want to work on camera animation, but the light objects overlays make that very inconvenient.

Is there a way to see in viewport camera objects, curve objects, mesh objects, but not light objects (but keep the lightness)?

$\endgroup$
7
  • $\begingroup$ The general solution to this is just to hide the blocking objects regularly (with H), and work in material preview mode or solid mode. Will this not work for you? $\endgroup$
    – TheLabCat
    Sep 24 '21 at 13:37
  • 2
    $\begingroup$ No, it is not the answer for the question, especially when you have dark scene lited up by many lights, and you are "hunting with camera" for best, cinematic speculars created by your lights. What about hiding all overlays (perhaps you'll say)? It wouldn't help either, especially if your camera is rigged, following curve and has empty as target. $\endgroup$
    – evilferber
    Sep 27 '21 at 12:12
  • $\begingroup$ Oh, I see! Yes, that would indeed require all the lights to be rendering 🤔. Sorry 🤪. Are you sure you cannot still go into camera view while the camera is hidden? One alternative would be to have two 3D viewports next to each other… I’m gonna see if the other guy’s answer fixed this. PS: it’s not lited, but rather “lit.” 🙂 $\endgroup$
    – TheLabCat
    Sep 27 '21 at 13:31
  • 1
    $\begingroup$ @TheLabCat Sorry about "lited" :) In complex scenes playback animation can be slower if you have 3D viewport opened few times, even in solid mode. Yes, I can go to camera view even if it's hidden, but I want to have empty (the target for the camera) shown, as well as paths. Thank you very much for all your trying, but I just wanted to know if there is an option to have rendered mode without lights overlays. $\endgroup$
    – evilferber
    Oct 1 '21 at 9:43
  • 1
    $\begingroup$ @evilferber Right ... seculars ... I'm going to delete my comments to clear it a bit here :) $\endgroup$
    – vklidu
    Oct 1 '21 at 10:35
2
$\begingroup$

I hope this is better: Another way I just found is to deselect the "Show overlays" button in the top right corner of the 3D-viewport window. Yes, you can't see the cameras :(, but when you want to see a specific camera or show keyframes or something like that, you can just select it in the "outliner" window (the one that has all the objects listed in it). Although this may be a little hard to work with, you still get your lighting and you can still see your cameras outlines when you select them.

$\endgroup$
2
  • $\begingroup$ I know all the stuff you wrote about. Won't work so well in my scenario. $\endgroup$
    – evilferber
    Sep 27 '21 at 12:15
  • $\begingroup$ I thought the same thing, but actually really needs full lighting, cuz he’s trying to get the camera position just right for a cinematic shot. $\endgroup$
    – TheLabCat
    Sep 27 '21 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.