0
$\begingroup$

I can see the volume and distant haze in the viewport, but the render the volume is not visible against the black background, and nothing visible against the objects which look in constant haze.

Additionally, why is the volume so "black" despite being lit by 3 light sources?

3D Viewport and Volume Nodes

Render View

I was sure to check to make sure the background wasn't transparent:

Film Settings

$\endgroup$
2
  • $\begingroup$ have you increased the number of bounces in your Render settings? By default the number of bounces for Volumes is set to 0. (Scene settings -> Light Paths -> Max Bounces) EDIT: I just realized you have those settings open in your first screen shot, and indeed it's set to 0! Try increasing that. $\endgroup$ Sep 23 at 19:40
  • $\begingroup$ Thanks a lot! Will give it a try. Also figured out the weird haze issues between density. The emissions somehow got nudged and was at 0.002 The preview only showed 0.0 so I didn't realize it was above 0. $\endgroup$ Sep 24 at 16:44
0
$\begingroup$

I think I may have solved it. I was adding procedural stars, and was still having the same issue, until I finished the tutorial and made the background not absolute black, but a little brighter, raising V value to 0.005, and when I rendered; bam, actual density was visible and more distant haze (though that is a bit strong).

Render Result

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.