What I want:

I want to take a model that has an albedo/diffuse, normal, ao, specular, gloss maps, etc. and I also want to add an emission map that will cause specific parts of the model to glow based on the colors represented in my emission map. Basically I want to achieve what this person seems to be doing with no issues: http://youtu.be/crMxJ6Ge1jE.

What I am getting:
The results that I get is that the emission map acts like a traditional stencil where whatever colors I paint on the emission map are cutout and whatever is underneath in the albedo/diffuse map shows up instead of what is on my emission map.

What I have tried:
I took a cube, created a material and a texture slot and textured it with a blue color like this:

albedo cube

I then created an emission map (green dot painted on it) and assigned it to a new texture slot. Here you can see the two maps that I am using.

albedo and emission maps

I have tried several emission map setups as follows:

Emission Map Setup #1

Influence (All defaults except):
Color unchecked
Emit checked with value of 1
RGB to Intensity checked
RGB 0,0,0 (Black)


Emission Map Setup #2 (tutorial method)

Influence (All defaults except):
Blend mode set to Divide
Negative checked

The tutorial method didn't work at all. With no lighting, the cube was pure black with no emission.

Here is the blend file (zipped)

  • $\begingroup$ You can use two spaces for a new line, you don't have to use <br>. View the markdown of my edit to see what I mean. $\endgroup$
    – David
    Commented Jan 27, 2015 at 21:44
  • $\begingroup$ Would you be interested in an answer for cycles? $\endgroup$
    – David
    Commented Jan 27, 2015 at 21:45
  • $\begingroup$ Thanks for the advice on formatting. I would like to know the answer for Blender Internal but if the answer also included Cycles that would be fantastic. $\endgroup$ Commented Jan 27, 2015 at 22:42

2 Answers 2


This method only works for the BGE not for the render internal nor Cycles, that's why in the tutorial you have to use some 2d filters to get the emissive effect from the emissive map, so the emissive maps do not generate emission, see the description below, this link is also avaliable in the tutorial web page:


If you want to generate emission, maybe you should use "Indirect lighing" with blender internal, or Cycles :)


You should probably read mataii's answer first. He brings up a good point and since watching a 10 minute video isn't something I wanted to do I did miss the point of the question a bit.

Several of the influence parameters for Blender Render(Internal) materials are only able to access the textures 4th component: the Alpha channel.

It would be nice if we could choose from (x,y,z,a) so that we could pack 4 masks into one texture and use that texture for Emission, Specular Intensity, Hardness, etc... but for now, if the influence uses a mask, that mask has to be in the alpha channel of a four component texture.

If you want your Emission mask to have color then also check off 'Color' :) For the Emission mask, you had "RGB to Intensity" activated right below Blend->mix under the Influence section. That causes the green to become blue so be sure to uncheck that.

The following image shows what happens when Emit is checked and there is no light in the scene. The object becomes bright blue and there is no hint of the green blob. That's because the Alpha channel for that image is pure white and this makes Emit 1.0 for every point on the model.

enter image description here

In the following image I have the Color Influence activated and set to 1.0 and the Emit influence set to 1.0 as well.

enter image description here

You can test the effect that an alpha mask has on Emission by going into Texture Paint mode and make sure that the Emission texture is selected. Now select Erase Alpha from the Blend menu.(If you use a pen tablet you should be able to skip that last step since the pen's eraser is supposed to automatically use Erase Alpha. It does for me so if it doesn't for you that's a bug report.)

enter image description here

I believe a quick animation is now in order and there is one sun lamp in the scene to show contrast.

enter image description here

For Cycles the Emission texture is plugged into an Emission shader and the same texture is also being used to control the mix factor for a Mix Shader that has a Diffuse shader plugged into the other input socket.

The Emit texture is routed through a 'Converter->RGB to BW' node since color should be avoided for masks. The Mix Shader uses black and white(0.0, 1.0) to determine the mix factor so we want to make sure that what goes in is also single a channel value. (This helps keep things predictable though not strictly necessary.)

For Cycles, the texture's Alpha channel doesn't matter here since your mask can be in any one of the channels and easily accessed using either of the "Separate XYZ/RGB" nodes. In this case all three color channels are the mask, that's why I converted to black and white. An better option would be to separate out the green channel and use that since it's the mask in this case and adjusting it would also adjust the others if they are still combined.

enter image description here

  • $\begingroup$ So do you concur with Mataii that it is not possible in Blender Internal to have a dimly lit scene where you can barely see the blue texture and have the green spot glowing (similar to what you achieved in Cycles)? That is what I am trying to achieve and I can't get that result with Color and Emit checked and RGB to Intensity unchecked, or any other combination of settings. $\endgroup$ Commented Jan 28, 2015 at 7:01
  • $\begingroup$ I sort of concur, with a quick test I was able to get the blue material to glow enough to light up the surroundings, sort of... for some reason the cube only lit up the areas for two sides of the cube and when I panned around, the background switched to only using one face of the cube for indirect lighting. I think it's very broken so you might have difficulties getting it to work as you intend. I just use Blender internal for baking. Sorry about that. $\endgroup$ Commented Jan 28, 2015 at 8:12
  • $\begingroup$ Well thanks for all the work guys. I guess BI really isn't going to do what I want. I have no problem getting Marmoset Toolbag or Maya to do it so I am just going to chalk it up as not working in Blender Internal for my personal workflows. $\endgroup$ Commented Jan 29, 2015 at 0:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .