0
$\begingroup$

I want to render a scene from a simulation that involves a particle system + quick explode. My particles get emitted by an object and everything looks correct in the viewport render.

But in the final render (Render Image), it only displays the emitter object and not the particles.

enter image description here

I played around and tried all combinations of Show Emitter, Visibility in Render etc., but it doesn't work. Also, I applied bake in particle settings > cache.

See blend file for details: https://pasteall.org/blend/c2afb5f482464b229715ca50ef0b9e3b

$\endgroup$
1
$\begingroup$

Disable under Properties window > Physics > Rigid Body for your particle object.
RB is not used in calculation of this sim anyway.

This can be the conflict – blender tries to sim RB and Particles at the same time.


NOTE: It is weird ... when RB is disabled for this object, object disappears from your Collection. You can find it in Outliner when you switch from current View Layer (outliner type) to Blend File (outliner type) ... inside Collections > RigidBodyWorld ... move it back to your collection. I would expect an oposit behaviour.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.