I have been tearing my hair out over this for three days and I have tried all the options given in previous posts. Whatever I do; bake or no bake, evee or cycles, checking that everything is visible ... etc. etc... but nothing works. enter image description here enter image description here The scene uses an ocean simulation and dynamic paint to create the ship's wake. The scene renders in the viewport but not when rendering. the only thing that I can think of ( and I've tried to diagnose it) is that the paint mask layer (labelled Col) in the shader somehow isn't working in the render... it masks out the wake because it is always blank. enter image description here Is there any diagnostic that I can perform other than 'suck it and see' and how do I fix it? I can't see what's being cached because the option to rename the cache doesn't work:- enter image description here If it helps I can supply the complete 'blend' file. This is the blend file link https://we.tl/t-ov7ubplyZ4

  • $\begingroup$ blend file helps in almost all cases...so yes, i would provide it $\endgroup$
    – Chris
    Commented Sep 19, 2021 at 12:18
  • $\begingroup$ the cache is in use and contains baked data. This might be the reason that you can't rename it. Delete the bake and try again. $\endgroup$
    – Blunder
    Commented Sep 19, 2021 at 12:22
  • $\begingroup$ I've tried clearing the cache both by 'delete Bake' and 'Delete all bakes' but it still doesn't allow me to rename the cache. I also tried with a very simple file without any other geometry than the plane with the ocean modifier... the rename cache continues to malfunction. $\endgroup$
    – JohnMoly
    Commented Sep 21, 2021 at 8:14

1 Answer 1


You have set the Geometry option of the Ocean modifier to Generate (default value). I am not familiar with the Ocean modifier but this seems to do very nasty things like removing the dynamic paint from the render but only if you press F12 for the final render. I can confirm that you always can see in the viewport's shading modes (Rendered, Material Preview, and Solid shading) but not in the final render.

This happens even if you have the place the Dynamic Paint modifier after it like you did. If you swap them then the dynamic paint will vanish from all shading views. For the latter case, the documentation gives us an explanation:

The Ocean modifier

Geometry - Generate

Creates a tiled mesh grid that exactly corresponds with the resolution of the simulation data.

When generating a mesh surface, the existing mesh object is completely overridden with the ocean grid; this also includes any data generated from previous modifiers in the stack. A UV channel is also added, mapping the (0.0 to 1.0) UV space to the simulation grid.


Set Geometry option to Displace.

modifier settings

Happy sailing!

final animation

About Renaming the Cache

I could give the cache a name with a simple double-click in 2.93.5RC. But I know sometimes Blender doesn't recognize double-clicks properly. Then I have to do triple-clicks. I've seen the problem once in the Blender Guru's donut tutorial (2.8). He also had trouble there with a double-click and used a triple-click (or two).

  • 1
    $\begingroup$ Brilliant! Solution works. That's good but the answer is even better; it explains exactly why my blend didn't work. All credit to Blunder! $\endgroup$
    – JohnMoly
    Commented Sep 24, 2021 at 9:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .