7
$\begingroup$

I rigged an object and animated it, and have set it as a hair particle (dupli object). It displays correctly, but animation is not being passed on... How do I make hair particle objects perform animation?

Note: I am aware that animation will be synchronized across all particles and am okay with that.

$\endgroup$
  • $\begingroup$ Hi there! I just checked it out and it works for me. I made a simple model, added a rig and animated it. Then I made a hair system an setted the hair particles as object: the model. And it works fine. What was your workflow? $\endgroup$ – Antonio Buch Jan 27 '15 at 9:18
12
$\begingroup$

You need to have your animated model and hair object on the same layer, or it won't update in the viewport (it will work only in render).

enter image description here

$\endgroup$
  • 2
    $\begingroup$ I could watch this all day long! $\endgroup$ – user1853181 Jan 27 '15 at 15:08
  • $\begingroup$ @Jerryno is there a way to randomise this animation $\endgroup$ – ashwin Mar 8 '15 at 23:52
  • $\begingroup$ @ashwin use the group option under particle render and put multiple object copies with different animations inside that group;) Enable Pick Random to pick randomly from the group. $\endgroup$ – Jaroslav Jerryno Novotny Mar 9 '15 at 11:47
  • $\begingroup$ @ashwin also rotating the hair particles randomly will help (Advanced > Rotation). $\endgroup$ – Jaroslav Jerryno Novotny Mar 9 '15 at 11:50
  • $\begingroup$ Does is work for a Emitter particle sistem as well? $\endgroup$ – Gatunox Mar 9 '18 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.