0
$\begingroup$

enter image description hereI was doing some animations in Blender 2.93, but in "Edit mode", the bone and the meshed body are separated from each other during animation, just as the pic shows. How could I solve this problem?

$\endgroup$
9
  • 1
    $\begingroup$ The Edit Mode is not for animating or posing but as the name suggests for editing the mesh. This means the underlying base mesh, not any deformed mesh created by modifiers, armatures etc. $\endgroup$ Commented Sep 15, 2021 at 8:56
  • $\begingroup$ Thanks, Gordon. So this is normal in edit mode? Doesn't mean the model was destroyed? $\endgroup$
    – blender987
    Commented Sep 16, 2021 at 9:10
  • $\begingroup$ It's not destroyed, just all movements, deformations etc. created by modifiers are deactivated to edit the mesh in its original basic form. The same applies for example if you simply have a cube and add a Subdivision Surface modifier, in Object Mode it gets rounded or spherical, but when you switch to Edit Mode it is shown as cube. That's the default way how Blender works. However, as the answer below shows, there are buttons that let you edit the model with the modifier's modifications visible. $\endgroup$ Commented Sep 16, 2021 at 10:04
  • $\begingroup$ I see. Thanks a lot, Gordon. You solve my confusion. I use the edit mode to get the coordinates of certain vert, this seems hard to do in other modes. And another question occurs, the coordinates of vert seems not to change during the animation, this is strange, what might be the reason for this? $\endgroup$
    – blender987
    Commented Sep 16, 2021 at 10:12
  • $\begingroup$ I have no idea, I never need coordinates of vertices for anything. I can only imagine that the coordinates refer to the local position in the original mesh relative to the object's origin point - i.e. where they are in the object, not in the world and without getting modified by any modifier. For example, the standard cube has 8 vertices with X/Y/Z location either 1 or -1. If you move the cube somewhere else or put a Subdivision Surface modifier on it, the vertices still stay at 1/-1 in Edit Mode no matter where they visually are in Object Mode. $\endgroup$ Commented Sep 16, 2021 at 13:11

1 Answer 1

2
$\begingroup$

In the armature modifier enable theese 2 little buttons:

enter image description here

$\endgroup$
2
  • $\begingroup$ what can I say? Little buttons help a lot. This is exactly what I am seeking. Thanks a lot. $\endgroup$
    – blender987
    Commented Sep 16, 2021 at 9:23
  • $\begingroup$ hi, josh, I have another question. I chose a vert for example 5254, its coordinates didn't change during the animation. What might be the reason for this? $\endgroup$
    – blender987
    Commented Sep 16, 2021 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .