2
$\begingroup$

I modelled this car starting from a plane and extruding it (which probably doesn't help), and now that it's finished I just realized when changing display mode from object to rendered that the faces look incredibly weird as if normals were screwed up. I recalculated normals several times, tried to do it manually, even reseted geometry data and recalculated vertex normals, but nothing seems to properly work, I don't know how to fix it !

I also tried applying the mirror modifier to see if it was an issue but it didn't help either.

Here's a picture of the car's normals info displayed

Picture of the model with all normal info displayed

And here's one in rendered mode in eevee

car rendered in eevee

And here's one in cycles that works just fine

car rendered in cycles

What confuses me is that it really looks like a normals problem to me, and yet playing with them doesn't change anything. Also backface culling is disabled.

I'm having this issue only on Eevee, as cycles doesn't seem to have the slightest problem.

Thank you for reading me, if you have any suggestion on what could be causing this I'll gladly take them :)


@MikoCG Heres my blender file : https://drive.google.com/file/d/1AHyoj9uimzPK-5pOAJKnQ_NIlTdkeV02/view?usp=sharing. I'm using the default principled BSDF material on my object but I don't know if it matters since when i swap for a simple Diffuse the render stays identical

@hamed.design I also already tried to merge vertices by distance before recalculating, there was no doubles and it didn't change a thing. I didn't find a "shell" modifier though ?

$\endgroup$
3
  • 4
    $\begingroup$ Can we see your material settings or file? It is weird, this looks like backface culling but if you say it is disabled and it works in cycles it sounds like backface culling $\endgroup$
    – MikoCG
    Sep 14 at 11:14
  • $\begingroup$ To me it looks like a bug and may suggest Eevee still has problems it shouldn't have, in this case with the mirror modifier. $\endgroup$ Sep 14 at 11:33
  • $\begingroup$ Try to hit tab and select all with a , and press "m" and click on "by distance" , and use "shift + n" to recalculate normals , then use a very small shell modifier , and test it out , and share the result with us , Or upload the blend file . $\endgroup$ Sep 14 at 11:41
0
$\begingroup$

Your material alpha mode is set to alpha blend, and blender is sorting the faces incorrectly, which unfortunately has been a natural limitation of EEVEE. Turn the alpha mode to alpha hashed or alpha clip, and it will solve the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.