0
$\begingroup$

Basically, a weird light speck tears through mesh every 10 or so frames of rendered material. Random, unphased by my bias settings (I was first having these issues with my emissive material + volumetrics, switched out for a simpler setup - everything in the file). Bias, glossy clamp, bloom or no bloom - it still happens. I have no idea why.

The top right corner - no bloom

This one doesn't even have a green light on scene!

Sorry but I really can't figure out what's happening - I've replicated a problem I was having in a project I'm working on, and I'm attaching a .blend file here.

I'm working in 3.0.0, but I just tried this in 2.93 - same deal. To reproduce you'd better render the animation, since it's a random thing and doesn't always happen.

Not tried this in Cycles, since it's of no use to me - I'd die before I render the needed stuff (I ran the numbers and it's 10 days of rendering). Here's hoping CyclesX comes out soon.

UPD: I have found this question: Blender Eevee lighting Rendering - Flashes of light in animation While it is probably the same issue as mine, people there focus on bloom, which, as I said, is not the culprit. There is a good suggestion there to re-render the faulty frames, but since I'm planning to do 5-6 min of animation, this could mean a ton of unnecessary work over something that shouldn't happen in the first place IMO.

I am considering rendering in some weird 66 FPS setting so that I may delete extra frames alongside faulty ones, but that's not ideal either, albeit less time-consuming.

Rendering the thing without volumetric lighting on didn't help. It still happens.

https://developer.blender.org/T77202 Apparently, this might be an NVIDIA driver bug. Welp. I will try to update it. Will keep you guys posted! This question is like my personal TODO page now.

$\endgroup$
2
  • $\begingroup$ I just rendered 10 seconds of that file and there is nothing wrong there for me, have you tried to append your scene to a new one? you could also use the volume scatter directly to the world instead of using a cube (if you want somw volumetric light). could be the gpu driver but i'm not sure about that $\endgroup$
    – Emir
    Sep 11, 2021 at 16:02
  • $\begingroup$ @Emir Everything points to it being a driver issue, unfortunately. I just installed a new version of studio drivers. Didn't help at all. The link in the OP leads to a vast and recent discussion of this. I see no other explanation - it doesn't look like anything blender is doing at all. Volumetrics on/off don't affect it. Thanks for your time, I really appreciate you trying to render this. $\endgroup$
    – Cowbless
    Sep 11, 2021 at 16:14

1 Answer 1

2
$\begingroup$

After a lot of testing, I have found a workaround - this happens even in a default project for me if I set Volumetrics>Tile Size to 2px. Setting it back to default 8px solves the problem. It's not intended behavior, but I'm glad I don't have to pick out faulty frames by hand in a 6min 60fps video! Cheers!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .