1
$\begingroup$

So I've been working in unreal engine lately and I've gotten an error about "bind pose", so I did a bit of research and I figured out that the problem is because of how my Metarig doesn't follow the advanced rig, and so the bones of the metarig are not connected to any mesh data during the animations which produces the error. I GUESS the solution could be to make the metarig follow the advanced rig, but I don't know how to do that. But perhaps there is a different solution, after all what I called "research" was really just a quick google search .Any ideas?

enter image description here

P.S - In the screenshot the red arrow points to the advaced rig- hip box. All I did was move it down a bit and you can see how the metarig doesn't follow along.

Thanks

$\endgroup$
0

2 Answers 2

2
$\begingroup$

You have parented the generated rig to the meta rig. This is not correct and not necessary. Select the rig armature and clear its parent (Alt+P).

The metarig is used only to lay out the bone structure on the mesh. It could be deleted after the rig is generated, but it is recommended to archive it in case you want to make changes. In that case, you can generate or update the rig again with the help of the metarig armature (see Generate Rig button and Advanced Options section).

The generated rig armature has the deform bones on layer 30, and additionally a lot of control and helper bones. For game engines, you need to export the deformation bones. Their names all start with the DEF- prefix and have the [X] Deform option enabled.

ue4 import

For UE4 (and Unity) there are add-ons that additionally fix some issues: Simon Orsborn / Rigify UE4 Exporter and this one: Rigify Export To Unreal Addon. (found them in the blenderartists.org forum).

Blender's export script for FBX files (File > Export > ...) has an option to export only deform bones. It's a bit hidden in the export dialog. On the right side, scroll down to the Armature section, expand it and tick the [X] Only Deform Bones checkbox.

$\endgroup$
1
  • $\begingroup$ Thanks! I ended up running into another issue of animations not playing, but I fixed the problem by just deleting the armature. It seems optimal to delete the extra rig and be done with all the problems it brings along with it. $\endgroup$
    – Dwoodle
    Sep 13, 2021 at 18:36
1
$\begingroup$

The best solution for the question is shown in this video by cg-dive. The tutorial is very helpful and easy to follow along, and had achieved exactly what I wanted.

And I also want to correct myself and say that, deleting the metarig is a bad choice since you are going to need it to apply ik to your character, and also when creating a physics asset there are going to be hundreds of collision bodies and that's going to make things greatly tedious, however if you opt to keep the metarig and follow the steps in the video, your physics asset will only have the necessary collision bodies that are needed to create an accurate and manageable physics asset.

Essentially we create a copy of the generated rig(or the game rig in this case) and we delete everything but the deform bones. Next we use a short script to apply the transforms of the generated rig to the game rig, and that's it. The process is a bit complicated but the tutorial is clear and easy to apply to whatever rig you created.

https://youtu.be/INK__p3CWUw

$\endgroup$
1
  • $\begingroup$ Hello and welcome. Please can you revise your answer to explain how you fixed it. Links can be used as supplementary information but should not be solely used as the answer itself as they can potentially get removed in the future. $\endgroup$ Jul 18, 2022 at 1:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .