I can't find how to mirror and bevel a bezier curve, if possible non-destructively, without converting to a mesh.

I just created a simple 2D bezier curve and filled it:

enter image description here

Then I applied a mirror modifier:

enter image description here

and I extruded/beveled the curve:

enter image description here

However, as you can see there is an ugly artifact on the part where the curve join. Any idea how to properly mirror a curve and extrude/bevel it?


I tried with the proposed method, it's a bit better (I did tried it before but I was missing the clamp overlap option). Artifacts are not that strong, but still present, especially when angles are sharp. I tried to apply subdivision surface, but the result is even worse. Unchecking "loop slide" improves the result a bit, but still not fantastic. Seems that handling bevel correctly is a very hard problem.

enter image description here


1 Answer 1


Sadly this can't be done with curve's builtin bevel function yet, Mirror modifier on bezier curves acts on the generated mesh level, not directly on bezier data unfortunately.

You'll have to fake it with modifier equivalents.

  1. Remove any native bevels you bezier curve has
  2. Add a Mirror modifier with merge enabled
  3. Add a Solidify modifier, set the desired thickness and optionally set offset to zero to more closely mimic curve bevel behavior
  4. Add a Bevel modifier, turn off the Clamp Overlap under the Geometry category
  5. Adjust the bevel radius as desired

enter image description here

Some artifacts are expected due to curves inherent bad topology. If necessary artificially subdivide the curve in Edit Mode and give it a few additional gratuitous vertex to enforce top face topology to change as required. Optionally retopologize before beveling, but it may lead to different artifacts.

Another alternative method to help with artifacts is using a Decimate modifier set to Planar before beveling. This will essentially turn the flat top faces into large ngons which may bevel better. Tight corners will still be subject to self intersections, much like bezier native bevel would. There really isn't in Blender an elegant solution for that other than manually fixing it.

  • $\begingroup$ Thanks for this method (and the /Clamp Overlap/ trick). As explained in my edit, I still have heavy artifacts (you also have some in yours, even if they are different and less problematic and sudividing with subdivision surface breaks everything)... But I guess bevel is a hard problem... Let me know if you have more tricks to help with sharp angles (I'll accept the answer meanwhille)! $\endgroup$
    – tobiasBora
    Sep 9, 2021 at 12:57
  • 1
    $\begingroup$ You can also try the Decimate modifier for artifacts, see updated answer $\endgroup$ Sep 9, 2021 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .