2
$\begingroup$

I'm making a 2D animation and i'm using some meshes to make the face and a Grease pencil object to make the mouth.

enter image description here

On viewpoint shading it's perfect, but when a render, the meshes get that washed-out color.

Already try to change the view transform but no work. What can I do?

$\endgroup$
6
  • $\begingroup$ Is one stroke object affected by lights and the other one not? $\endgroup$
    – TheLabCat
    Sep 8 at 23:18
  • $\begingroup$ Looks like its the mesh getting lighter, not the grease object getting darker... you could try using the color picker on the render to match the grease pencil color with the mesh perhaps? $\endgroup$ Sep 8 at 23:26
  • 1
    $\begingroup$ @TheLabCat the head is made with various meshes (Plane object) and only the mouth is a grease pencil object. How I can disable the light affecting these planes? $\endgroup$ Sep 8 at 23:31
  • 1
    $\begingroup$ @NascentSpace I can use the color pick, but the washed-out color will continue. $\endgroup$ Sep 8 at 23:33
  • $\begingroup$ If this is EEVEE, just use an emission shader. $\endgroup$
    – TheLabCat
    Sep 8 at 23:35
1
$\begingroup$

FOUND: change the material surface from Principled BSDF to Toon BSDF make the trick.

enter image description here

The Material preview is now with the wrong color, but the Render is right and that is what matter.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.