2
$\begingroup$

I am tired of this error and unable to Knife Project in Blender. Photo Attached:-

enter image description here

$\endgroup$
4
  • $\begingroup$ "Regression"? Wdym? $\endgroup$ Sep 6 '21 at 15:17
  • $\begingroup$ You either need to select 2 objects, or you need to delete the faces (X (Delete) > Only Faces on your cutting object. I guess it's one of these problems $\endgroup$
    – moonboots
    Sep 6 '21 at 15:19
  • $\begingroup$ I've tried all this. I have used knife project before & it worked. But it isn't now. $\endgroup$ Sep 6 '21 at 15:20
  • $\begingroup$ So it may be a bug as Marty says $\endgroup$
    – moonboots
    Sep 6 '21 at 15:33
5
$\begingroup$

Knife project has changed in 2.93.4.

The new method:

  • Select the destination object in object mode. Do not select the cutter.
  • Enter edit mode. (Shortcut: Tab)
  • Select the cutter in the outliner (or by Ctrl–left-clicking the cutter).
  • Perform the knife project.
$\endgroup$
3
  • $\begingroup$ But Why? (rhetorical) That's really inconsistent with Blender's notion of an 'Active' object or selection everywhere else. It seems nuts, to me, until I hear a justification. $\endgroup$ Sep 10 '21 at 9:25
  • $\begingroup$ It's not listed in the changelog, so I suspect it really is a bug. If I get time, I'll look at the git repository to see if I can figure it out. $\endgroup$ Sep 10 '21 at 13:48
  • $\begingroup$ Ahhh.... Sorry, no trouble intended. $\endgroup$ Sep 10 '21 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.