blender newb here. I've exported a .dae from Revit using the lumion plugin in Revit and I'm trying to follow this tutorial.

My issue is that when I import the .dae to blender. Everything shows up black.

In the comments, someone has suggested checking the alpha channels to see if they are all set to 0...which I find to be my case. They then suggest changing all the alpha channels from 0 to anything above.

Here is the alpha setting I am referring to: enter image description here

I am finding myself having to go through each blender object and setting the alpha one by one. Is there a faster way to do this besides scripting? also, I have no idea what the alpha setting is for so any insight on that would be appreciated.

I've tried selecting multiple objects and changing but it only changes the last one I selected. I've also tried mouse drag over all and set it but it's still the same result.

Here is what my scene looks like. The black objects have the 0 alpha enter image description here

Any help/direction is appreciated.

  • $\begingroup$ what do you mean with blender object? do you mean the material? $\endgroup$
    – John MC
    Sep 6, 2021 at 5:05
  • $\begingroup$ @JohnMC, I've updated the question with some images to give it more context. I believe this answers the question. lmk if you need any more information. $\endgroup$
    – Cflux
    Sep 6, 2021 at 5:27

2 Answers 2


I'm not aware of one besides scripting. Here is a script that should do it:

import bpy

for mat in bpy.data.materials:
    if not mat.node_tree: continue
    for node in mat.node_tree.nodes:
        if node.type == 'BSDF_PRINCIPLED':
            soc = node.inputs["Alpha"]
            if soc.is_linked or soc.default_value > 0.01:
            soc.default_value = 1.0

Alpha is a transparency value: 1.0 is opaque and 0.0 is completely transparent. However in Eevee for it to work you must also set the material's "Blend Mode".


If you want to set a parameter for a bunch of selected objects through UI (if they share a same kind of property) just enter the value and while holding Alt press Enter, or hold Alt and drag the value to set it for all of them


Although it works for any property that share a same address this doesn't work for material properties and it's weird!

  • 1
    $\begingroup$ This doesn't work with materials, because they are node-based $\endgroup$
    – Crantisz
    Sep 6, 2021 at 6:05
  • $\begingroup$ @Crantisz if their nodes be just as same, it works. the concept behind is .path_resolve() method and if values have the same address, it should work. $\endgroup$ Sep 6, 2021 at 6:20
  • $\begingroup$ Nope. Just test it $\endgroup$
    – Crantisz
    Sep 6, 2021 at 6:21
  • $\begingroup$ @Crantisz I am testing for a set of complex values and it works! $\endgroup$ Sep 6, 2021 at 6:23
  • $\begingroup$ Test simplest materials. $\endgroup$
    – Crantisz
    Sep 6, 2021 at 6:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .