1
$\begingroup$

No idea how these happen aside from the vertex points just merging through existing geometries. This is disruptive to my workflow. I admit I sculpt everything I do so the faces are always at least a little bit messy but this is just eyesore-ish.

$\endgroup$
1
  • $\begingroup$ if you sculpt with Dyntopo you won't avoid triangles, therefore bad topology, if you want a good topology you need to retopologize manually (or at least use Remesh, it will be ok for organic objects). To fill holes you have some technics like find holes or boolean. $\endgroup$
    – moonboots
    Sep 5 at 19:32
1
$\begingroup$

I'm afraid I cannot help you on the 'why' front, but I may have some solutions:

  • Remesh your mesh (Remesh modifier/Voxel remesher), this is the most obvious and probably worst option as I assume you're welding it to decrease vertex count and remeshing without losing detain usually requires low voxel size and thus more verts, try to use the adaptivity option
  • Use the weld modifier, turn On Cage (the upside down triangle next to square) to see the effect on the mesh in edit mode and then manually move all the offending vertices
  • Try other similar operations like the Decimate modifier, with some tweaking I managed to get very similar results
$\endgroup$
1
  • $\begingroup$ That's the exact steps that leads to these weird crisscrossed faces and vertices, unfortunately. However I've moved to using Instantmeshes to remesh pieces and that seems to help sometimes. $\endgroup$ Sep 24 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.