1
$\begingroup$

I've been modeling for just under a year, and I hit random keys by mistake. This time, I can't figure out which one I hit. In modeling some stairs, I accidentally messed up the steps.

I was trying to hide the steps so that I could get to the supports easier, and after modeling on the supports, I unhid the steps, and they looked smooth-shaded.

Smooth Shaded or rendered?

With the black smudges, it also looks like it could be rendered, but that doesn't make sense to me (Could be possible)

I tried to shade flat in object, and edit mode, though that didn't help matters.

Shaded Flat doesn't respond

What on earth could I have done? I can't (I could, but would like to figure it out at this point) undo to the point that I did it, and really need to figure out what happened.

Thank you very much for your help!

EDIT: Blender version 2.93.1 - Here's the blend file. Thank you. Also, another picture to help drive the issue home. The stairs look smooth-shaded, but they're not supposed to be smooth. Trying to smooth flat results in no change.

Smooth-Shaded stairs but not

EDIT 2.0 (Fix) - The issue was that I hit the hotkey for "Auto Smooth" This is different than "Shade-Smooth", so there was no effect in changing to Shade-Flat.

Select your model in either object or edit mode. And open Object Data Properties on the right. Scroll down to Normals, and uncheck "Auto Smooth"

Uncheck Auto Smooth

A suggested topic on the right is what ultimately led me to the discovery. Thanks to everyone who helped!

$\endgroup$
5
  • $\begingroup$ Could you share your blend file in your question? (Grab the URL of the question. Go to blend-exchange.com. Select the blend file. Add the url of the question. Grab the url that results. Go back to the question and edit it. Add the new url to the bottom of the post.) $\endgroup$ Sep 4 at 0:07
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Sep 4 at 0:08
  • $\begingroup$ To clarify, the model looks shaded smooth on the steps part of the model, but it's not shaded smooth. Incoming blend file shortly. $\endgroup$
    – Mutim
    Sep 4 at 0:15
  • $\begingroup$ @Moderator: I uploaded a better screenshot with how the steps look, and how the rest of the model looks in hopes to infer what the steps should look like. $\endgroup$
    – Mutim
    Sep 4 at 0:21
  • 1
    $\begingroup$ Auto Smooth was enabled. There was a suggested topic on the right that led me to find the answer. I have tried finding what hotkey is used to enable that, though I can't find it anywhere. Thanks for all of your help! Happy modeling =) $\endgroup$
    – Mutim
    Sep 4 at 0:33
1
$\begingroup$

You have a shading issue because you must have changed the split normals. Go into Object Data > Geomertry Data and Clear Custom Split Normals Data. Also recalculate the normals (ShiftN when in Edit mode).

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you for your response, however, the issue was in fact that I had Auto Smooth enabled. After looking in Geometry Data, there was custom split normals, but that wasn't what led to the shading issue. Since you pointed that out, I went ahead and removed the custom data, and exported it. Thank you again for taking the time to help me with my issue. =) $\endgroup$
    – Mutim
    Sep 4 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.