6
$\begingroup$

I have two planes with the same node setup, but only one of them is transparent in Material Viewport Shading.

enter image description here

The one that works was created by the Import Images as Planes addon. The other plane was created manually and copying the addon's material setup into a new material.

If I set the addon's material to the "bad" plane it works, so the problem is related to the material itself (nor the object, OPGL or my hardware). I'm working on 2.73.

I have no clue about this behavior, here is the .blend for checking it out.

$\endgroup$
  • $\begingroup$ I'm going to work in some camera mapping videos soon and having this working is mandatory for checking the camera animation in real time. Importing Image as Planes is not a solution, I need to be able to set up the material myself for every meshes which are going to have the projection. $\endgroup$ – Antonio Buch Jan 24 '15 at 13:12
  • $\begingroup$ @stacker It's weird. I'm on 2.73 too... Just checked on two other PC's. One is AMD but both are NVIDIA. $\endgroup$ – Antonio Buch Jan 24 '15 at 13:17
  • $\begingroup$ sorry I misread the question, I thought viewport shading set to rendered. $\endgroup$ – stacker Jan 24 '15 at 13:36
  • $\begingroup$ I meant AMD CPU! :P $\endgroup$ – Antonio Buch Jan 24 '15 at 13:47
  • $\begingroup$ @AntonioBuch it does look like a bug. I tried with different image and got the same result: recreating the material I couldn't see transparency. When using import images as planes I could... $\endgroup$ – user1853 Jan 24 '15 at 16:17
6
$\begingroup$

Version 2.76 and after:

See TimCollinsMedia's answer

Prior to version 2.76:

This is highly illogical and probably should not effect the display at all, but the setting that makes those two differ is "Alpha blend" in Blender game engine material settings.

Change the rendering engine to "Blender Game", and change this setting from "opaque" to "Alpha blend" in the material settings, then change back to cycles.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ How did you figure this out?... very strange indeed $\endgroup$ – user1853 Jan 25 '15 at 7:23
  • $\begingroup$ but he says its cycles $\endgroup$ – Shaiq Jan 25 '15 at 18:00
  • $\begingroup$ @Shaiq This is in the viewport (OpenGL), and I guess some obscure OpenGL settings are affecting the way it draws. hjaarnio Nice detective work, +1 :). Perhaps this will be fixed with the upcoming OpenGL overhaul. $\endgroup$ – gandalf3 Jan 25 '15 at 20:10
  • $\begingroup$ Is it possible to #tag users here since this is likely the guy who will be repairing this issue. blender.stackexchange.com/users/465/psy-fi $\endgroup$ – MarcClintDion Jan 26 '15 at 3:29
  • $\begingroup$ I guess I should have tried it before asking #psy-fi Let's see if it summons him. $\endgroup$ – MarcClintDion Jan 26 '15 at 3:29
10
$\begingroup$

I think I've figured this issue out. I'm in Blender Cycles.

To see the transparency, make sure you're in the "Material" view in your viewport.

With your image-plane selected, go to the Material tab.

Toggle down "Settings" at the very bottom. Make sure "Viewport Alpha:" is set to something other than "Opaque". I find "Alpha Clip" and "Alpha Blend" worked well for the .png image I was using.

Hopefully this answers your question.

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ This answer is quite right and it's actually the method I use. Though, at the moment of my question, @hjaarnio 's answer was the correct one. I don't know if I must change the question itself to specify that it is a query concerning to 2.73 version. $\endgroup$ – Antonio Buch Feb 13 '16 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.