0
$\begingroup$

For some reason when I render the object in viewport 3D Render I see these lines that look like weird shading or geometry. But I have fixed this in the Solid Viewport where they don't show up. Also I noticed I only have this problem in Cycles if I turn the Engine to Eevee it looks normal. How do I solve this? enter image description hereenter image description here

$\endgroup$
9
  • 1
    $\begingroup$ Can you post your wireframe? $\endgroup$ Sep 2 at 2:22
  • $\begingroup$ I uploaded the images here both in wireframe and with normals. The normals seems ok and I already used autosmooth and shade smooth on the object, but I tried reapplying it again to see if there was any change but nothing happend. I also tried flipping the normals but that just made it worse. The strange thing is also if I render the object in Evee it looks all perfectly smooth but when I change it to Cycles it becomes deformed like this in the viewport. $\endgroup$
    – Blendmoth
    Sep 2 at 4:38
  • $\begingroup$ hello, could you please share the object? pasteall.org/blend $\endgroup$
    – moonboots
    Sep 2 at 4:46
  • $\begingroup$ pasteall.org/blend/2c732370d43a4870890836ba8c752050 $\endgroup$
    – Blendmoth
    Sep 2 at 5:07
0
$\begingroup$

It could be any number of things, if you post the wireframe, or the area in edit mode that could help narrow it down! :)

Some stuff to try, though:

  • Merge vertices by distance to get rid of any doubled up geometry.
  • Turn on Auto Smooth in the Object Data Properties>Normals area and mess with the Angle until it looks good and see if that helps. Probably not but sometimes auto smoothing can force things to work when they otherwise wouldn't.
  • Re-apply Shade Smooth - Seems simple but sometimes after changes, particularly when sculpting, but sometimes in other areas as well, the shading smooth needs to be reapplied to take effect on the altered area.
  • Check your normals. enter image description here In edit mode, use the overlay drop down as pictured and near the bottom tick the Face Orientation option and see if the problem area has any RED. If it does it means the face is not oriented correctly and needs to be flipped. Select it or the entire mesh while still in edit mode and hit Shift+N to flip normals.
  • Fix geo. This sounds obvious but these problems usually don't show up if the geometry is solid. Make sure there's no edges split, no loose vertices, non-manifold geometry etc.
  • Try adding the Weld modifier to the mesh or applying modifiers if you have any attached to the mesh in question, sometimes they can cause issues that may show up until they are applied.
$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.