2
$\begingroup$

I'm trying to model a cotton garment by simulating it's draping process. I'm having issues only when I enable self-collision of the cloth. Without self-collision , there are no issues but I do need self-collision for later stages of work and can't proceed without enabling that. I'm using 2.73, and I didn't modify any settings; that is , I use the default collision settings and for everything else too. Below are screenshots of the issue.

Rest state:

enter image description here

End result, without collision, close to what I want; but as seen, cloth is penetrating itself:

enter image description here

When I enable self-collision, this happens right from the 1st frame itself:

enter image description here

The end result is also similarly messed up.

These are my cloth settings:
enter image description here

I believe that the simulation is finding the cloth particles close together and hence repelling them from each other, given the messed up result. I set the "distance" value in the collision settings to 0.5 and 1 too, but both of them gave the same result.. Any idea why this could be happening?

$\endgroup$
  • $\begingroup$ In your screenshot Blender states, that the cache is outdated. The first thing i'd try is to clear the cache (e.g. set frame to 1). $\endgroup$ – user2859 Jan 23 '15 at 17:29
  • $\begingroup$ Have you tried bringing down the self collision Distance value? $\endgroup$ – cegaton Jan 24 '15 at 1:35
  • $\begingroup$ Yes, I tried 0.5 as well..same thing.. $\endgroup$ – sanjeev mk Jan 24 '15 at 4:53
  • $\begingroup$ Apply rotation and scale. Just got same problem. $\endgroup$ – user11306 Jan 29 '15 at 23:10
  • $\begingroup$ @PiotrJędrzejko Didn't get you exactly...rotate and scale what? $\endgroup$ – sanjeev mk Jan 30 '15 at 8:36
0
$\begingroup$

A POSSIBLE WORK AROUND (that at least worked for me):

Scale up everything, then apply the transformation (CTRL+A > all transforms)

Sometimes cloth simulations in Blender results in error with too small meshes.

Hope this may help.

G

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.