1
$\begingroup$

i made a camera follow a curve with the option Ctrl + P (Follow Curve) and it works good except for the fact that when the camera reach a vertice (curve) it turns too abrupt, is there any way to fix this? i tried with the graph editor...but i see no keyframes... Help! :(

enter image description here

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ Use the curve only for position and control the camera rotation separately (keyframes, track_to with influence, ..) $\endgroup$ – Jaroslav Jerryno Novotny Jan 23 '15 at 13:54
  • $\begingroup$ Or put a softbody rig between the curve and camera as a damper and simulate it (works like a steadycam) $\endgroup$ – Jaroslav Jerryno Novotny Jan 23 '15 at 13:55
  • $\begingroup$ You can increase the curve resolution in the properties data tab (Resolution - Preview U). Could you upload an image? Not sure if that is your problem. $\endgroup$ – user2859 Jan 23 '15 at 13:56
  • $\begingroup$ I uploaded a picture there $\endgroup$ – beavoru Jan 23 '15 at 14:03
  • $\begingroup$ Use constraints instead of "Follow path". Then you can animate the rotation of the camera at the frames you want =) $\endgroup$ – Einar Jan 23 '15 at 14:10
4
$\begingroup$

Undo the parenting that you did with CTRL + P. It's handy, but it's limited.

Then select the camera and go to constraints. Select constrain "Follow path". enter image description here

Then choose the curve as target, in the constraints menu. enter image description here

Now you can select the curve and go to the "data" tab(the one that looks like a curve). Under "Path animation" you can animate how fast and far the camera will move on the curve.

enter image description here

If you select the camera, you can animate the rotation as a normal animation(You can reset the position of the camera with "alt + g" to snap it to the curve).

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ Here i also uploaded a video: dropbox.com/s/as751siajpqetsc/clip0003.avi?dl=0 $\endgroup$ – beavoru Jan 23 '15 at 14:51
  • $\begingroup$ I see. Try the solution that I've posted - it should solve your problem. But don't use the "Follow" option under "Path animation". You want to animate the cameras rotation manually. $\endgroup$ – Einar Jan 23 '15 at 15:14
  • 1
    $\begingroup$ "Follow path" when you parent(CTRL + P) forces the camera to rotate along with the path. The abrupt rotations you are experiencing will always be present in abrupt turns. Unless you animate the rotation manually, like I've suggested =) $\endgroup$ – Einar Jan 23 '15 at 15:17
  • $\begingroup$ Sorry, i wasnt able to answer before, the Follow Path option doesn't work, the camera doesnt follow the path or animates (it just doesn't start) $\endgroup$ – beavoru Jan 26 '15 at 15:46
  • 1
    $\begingroup$ After that you keyframe the rotation of the camera. This is done by selecting the camera, not the path, and animating normally. $\endgroup$ – Einar Jan 26 '15 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.