2
$\begingroup$

We are making a game - project (demo one) - the issue appear, when I made some changes on ones of the Linked object to the main scene. I did SaveUs, close the scene and the new save us won't start at all. Blender crashes on open without any warning messages. I've try check the Toggle System Console, but crash as a blink of an eye. I found blender.crash.txt in temp folder but was empty.

enter image description here

What I did: 1. Restart the comp

1_2. Try to run the file with different name

1_2. Try to run both Backup files. ..

  1. Remove all additional add-ons (load factory settings)

  2. Try to run the last file from the prompt

  3. Deleted all temp files - connected to blender

  4. CC clean the registry for any issues

  5. Restarted again - but still doesn't work

  6. Copy the main scene of the project I did(contained all stuff in), to external drive and try to run from another computer powerful then mine: but same result, doesn't work at all

  7. Start reading articles and similar bugs(errors) around the net - I couldn't found similar issue

  8. Optimize and update driver of my Nvidia GTX 750 Ti - still no results

  9. Install the previous version of 2.72b and try run the file there - without success

  10. Uninstall blender at all and Installed again, no results

[Just to mention that for those several years of Working and Using Blender as primary 3D Software in my workflow, I haven't recognized or experienced such a glitches, bugs etc. Just Blender works perfect for me so far!]

Then, I re-open the Main Scene, which still working, I run the Toggle System Console, and this appear

enter image description here

Missing meshes, missing textures etc. Well Is there any option suggestion how to fix this BUG? And to continuing the project? Why I'm calling it Bug because I've done some experiments to simulate same mistake, for registering the problem, but is very difficult for find where exactly is the problem, someone should explain me a bit more about the LINKs and connections into the CODE, how they communicate to each other. For example I've did this test.

Is there any way to fix this links, or to change them somehow... without opening .blend file in Blender. For example additional Python software or application where this code relation could be fixed into the file which crash on open?.

enter image description here

In this preview after I linked an object (the complex one), I opened it from the linked library short button, then click Linked data, then Make Single User then go back into the container file. Save and quit. (Please look at the preview above).

After that, I opened another default scene after I linked the same object into it and try to push the short button of Linked Library, and this message appear:

enter image description here

We will appreciate any kind of suggestions and accurate technical support! Thank you

$\endgroup$

closed as off-topic by Ray Mairlot, user2859, Jaroslav Jerryno Novotny, user7952, Polosson Jan 23 '15 at 15:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question appears to be off-topic because it is a bug report and not an actual question. These should be reported to Blender's tracker instead." – Ray Mairlot, user2859, Jaroslav Jerryno Novotny, Community, Polosson
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ THE CURRENT SITUATION: 1. I've open the working previous Main File, try to make all paths from relative to absolute and back, make materials Single User, Unlinked them manually, right click and unlink, make them local. 2.Into Blender Preferences, file-paths - give new file-paths 3. Make new Save As, and close Blender I open the new one and it works.. ! But the problem is that I can't open the scene of our last work and updates. Were we spend a huge amount of time. ... $\endgroup$ – Ivaylo Jan 23 '15 at 12:54
  • $\begingroup$ Interestingly had I some issues with 2.73 corrupting files so it would segfault. Haven't been able to track down the cause (a way to reproduce the issue) yet, but in my case it was the undo history. What you could try is -> in user preferences disable: File->LoadUI and Editing -> Global Undo and set Steps to 0. Anyway, this should go to the tracker. $\endgroup$ – user2859 Jan 23 '15 at 12:54
  • $\begingroup$ Also, when you go to the tracker it would be nice to upload the blend in question. $\endgroup$ – user2859 Jan 23 '15 at 12:59
  • $\begingroup$ I will report it to the tracker. Right now I've changed Blender from 2.73 to 2.72b cause .72b works well for me. Do you think is there a way to fix this links, or to change them somehow... without opening .blend file in Blender. For example additional Python software or application where this code relation could be redact into the file which crash on open (the scene with last updates). $\endgroup$ – Ivaylo Jan 23 '15 at 13:06
  • $\begingroup$ It depends, but if the file isn't utterly corrupted it should be possible with blender and a debugger. $\endgroup$ – user2859 Jan 23 '15 at 13:10