0
$\begingroup$

This is supposed to be a game asset and the top of a toaster. I have some boolean cuts in the top and the shadowing seems to be ok after check it out with matcap, as you can see here:

enter image description here

But after that, I would like to round the corners of the cuts, and then, some weird shadow artifacts appear on the corners. I have tried different topology, even boolean cutting the rectangles with rounded corners, but I still got weird shadows. I even recalculated normals, but the result always ends looking like this or this: (depending if I use triangles or knife cutting the rounded corner vertices on the mesh).

enter image description here enter image description here

This is the topology I'have tried, among others:

enter image description here enter image description here

Sorry, this is probably a newbie question, but I really don't know how to fix it. I hope I can learn from this.

$\endgroup$

1 Answer 1

0
$\begingroup$

enter image description here

Try checking the auto smooth option in the object data properties, maybe it should work and if it does but changes other stuff, change the angle till its all good... Hope it helps

$\endgroup$
2
  • $\begingroup$ Thank you for answering! I have auto smooth enabled at 30 degrees. After your answer, I tried new angles, but still no luck… $\endgroup$ Sep 1, 2021 at 11:25
  • $\begingroup$ Are you applying the boolean with round modifier ?? If so, I think you have to fix the mesh in edit mode... $\endgroup$
    – CG Roebuck
    Sep 2, 2021 at 13:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .