13
$\begingroup$

I'm rendering an animation with motion blur (Shutter: 0.7) of a flyover of a bridge with moving cars on it.

The problem is that the cars get transparent as seen in the image. Can this really be the correct behavior or is something wrong with the motion blur implementation? And if that is the cause, any idea on how to fix it?

The train is also moving but is shown correctly. The cars are made from a particle system, that renders a group of cars, while the train is an actual model.

image

Second render without Motion blur:

No motion blur example image

Edit: I did some further testing and here's the result: motion blur is broken together with curve-guide. I've created an emitter emitting one particle shown as a box (with the group option). There's a curve-guide guiding the particle. To the right, there's a box, animated by hand with keyframes to follow the motion of the particle. They have almost the same speed. Clearly it messes up.
Rendering Wire

Now I would like to know if there is a another way to make my cars follow the road. I could try a lattice which doesn't have the rendering issue, but it's not as precise. As suggested by gandalf3, I could use the keyed particle system, but I can find no way to get a uniform speed along the way.

Lastly, should this edit be in another question? I'm not that familiar with the Stack Exchange norms.

$\endgroup$
  • 1
    $\begingroup$ I doubt that the motion blur would be the cause. Have you rendered with motion blur turned off? Are you compositing the final image? If your willing to share the blend file it may help someone find the issue. $\endgroup$ – sambler Aug 13 '13 at 7:37
  • $\begingroup$ It could be the motion blur: In case the particles disappear (dead or unborn) in the motion blurs sample frame-range, you could get a slight transparence. $\endgroup$ – Róbert László Páli Aug 13 '13 at 8:03
  • $\begingroup$ The motion blur is definatly part of the problem; here's a render without: dropbox.com/s/asrxlwkv3h5eico/frame270.png Also, the particles are not disappearing for more than 100 frames after the rendering shown, so that can't be the issue either. I am compositing, but the problem is in the raw render. unfortunately, I'm not able to share the file. $\endgroup$ – Wedel Aug 13 '13 at 8:51
  • $\begingroup$ And before the current scene? $\endgroup$ – Róbert László Páli Aug 13 '13 at 13:10
  • 1
    $\begingroup$ @Wedel Adding info about why the issue happened is fine. It is better to keep each post as one question, so you would be better off with a new question of How can I animate cars moving along the bridge? $\endgroup$ – sambler Aug 16 '13 at 10:50
8
$\begingroup$

It seems I have found a solution now.
In the Particles-tab there's a Cache option. If the particles are Baked they render properly even though there is a curve-guide affecting them.
enter image description here

$\endgroup$
6
$\begingroup$

Blame the particle system. Motion blur only work on the Object level. Deformation motion blur is not working properly. Do you have keyframes on your particle system? If so blender will render motion for all the geometry inside of that object, your particle system.

Edit:
gandalf3 made a good point in his answer too. Anyway, you might want try and render out a motion vector pass. And leave cycles motion blur off for the render and then in the compositor add motion blur.

enter image description here

$\endgroup$
  • $\begingroup$ I don't have keyframes on the particle system, but I have two curve-guide-force-fields, one for each direction, affecting the particles. They each have a Max distance to only influence the particles in their direction. I've had some issues with the vector blur previously, so I would very much appreciate to avoid it. I did some small tests with the curve-guide-field and it seems to give some unpredictable results, i.e. suddenly an insane amount of blur, so I guess the problem lies there. I'll try to use keyed particles or a lattice to control the direction instead. $\endgroup$ – Wedel Aug 15 '13 at 5:40
  • $\begingroup$ I don't have the Z and Speed slots on my Render Layers node :/ Is it still up to date ? (v2.79 here) $\endgroup$ – gordie Jun 30 '18 at 14:26
1
$\begingroup$

To expand on user320's answer,

It seems that if you animate your emitter object, the particles will be motion blurred with the Emitter motion.

Presumably, this will be fixed with the addition of Deformation motion blur.

Possible solutions depend on the requirements of the car motion, but basically a method that does not require moving the emitter should work. (Perhaps a boids or keyed system)

$\endgroup$
  • $\begingroup$ I didn't know about the keyed system, so I'll give it a try. $\endgroup$ – Wedel Aug 15 '13 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.