0
$\begingroup$

I'm trying to bake Specular Map.

I have 2 materials. If one of them has Specularity - 0 and another one has - 1, it works correct. Not specular - black color, specular - white color. But any middle number (or grey color, or any map) it bakes as white. I set Bake Type to Glossy.

enter image description here

Please explain me what is the problem. Thank you!

$\endgroup$
1
  • $\begingroup$ Do you need to bake this in the first place? If you use the same value everywhere, you don't need an image texture, just write the value as is. $\endgroup$
    – L0Lock
    Jan 2 at 16:20

2 Answers 2

1
$\begingroup$

The specular input of a principled BSDF is not the same as specular color. Principled's specular is much more akin to a remapped Fresnel or IOR. The specular color of a principled BSDF is derived from the base color instead.

In earlier versions, Blender baked only by pointing a camera down the normal of the sample. This mostly makes Fresnel, a view dependent effect, irrelevant to bakes.

In current versions (4.0.1 or around then), the specular settings have been renamed to IOR level which should dispel some of the confusion, and you can now bake from an active camera rather than above surface in order to get view dependent effects like Fresnel:

enter image description here

As Blunder offers, if your goal is just to bake some color, just bake it as emission-- that's the best way to get exactly what you want, when you know exactly what you want.

$\endgroup$
0
$\begingroup$

I'm not sure if Specular is the same as Glossy and I have no idea why this black/white conversion occurs. The documentation is not helpful here: "Glossy - Bakes the glossiness pass of a material."

I would just bake the Emit type and you'll get what you see. Plug the desired node into an Emission node or use the preview function of the Node Wrangler's addon:

baked emission

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .