1
$\begingroup$

I made my first low poly model and I want to put this character into Unreal and animate it in Blender first, so I rig it with Rigify the Blender plugin.

I add bones and I generate it and it's all working so far, but here is the problem.

After I generated it and I went in pose mode when I click on a line to drag and move the body it starts a box select instead of moving that part of the body. One other thing I have noticed is when I am in object mode and move around the character the bones nor the armature follow it, is that supposed to happen.

Sorry if this is a common problem, I am new and have no clue what is going on, I have searched this up and I can't find any solutions.

In this image I have selected a line and tried to drag it but it uses box select in this image I have selected a line and tried to drag it but it uses box select

$\endgroup$
13
  • $\begingroup$ This does not sound like correct blender usage. With a basic armature, one must select the bone, then somehow rotate it. One option is to enable the rotation gizmo via the left sidebar, another is to press R, and a third is to edit the properties directly in the right sidebar or in the Properties editor. I don’t think one can ever flat out drag a bone. $\endgroup$
    – TheLabCat
    Aug 30 at 4:14
  • $\begingroup$ Have you used the "parent with automatic weights" operation for the rig and the mesh? In the screenshot, it looks like you have box select enabled. If you want to move a bone you have to grab it first (key G) or use the gismo, as TheLabCat suggested. The red and yellow bones are IK control bones. You can move and rotate them. The green ones are FK control bones. They cannot be moved but only rotated. The root (the large circle with the 4 arrows at his head) doesn't look right. It should be down on his feet. Have you applied the Location for the rig and the mesh before you parented them? $\endgroup$
    – Blunder
    Aug 30 at 7:55
  • $\begingroup$ Ok thanks for your answers I think the red arrow is at its head becuse thats where the cubes original location was and I extened down and did not move the mesh up $\endgroup$
    – Othie
    Aug 30 at 16:05
  • $\begingroup$ As for thelabcat when I press R or use the rotate gizmo, it move the lines and dose not move the bones or the actual character object. I am assuming that is not supposed to happen. And for when I said just drag the bone I saw it in a video about rigging with rigify link:youtube.com/watch?v=DS885Sk1gSs I did not see he pressed G to move $\endgroup$
    – Othie
    Aug 30 at 16:08
  • $\begingroup$ and btw I think I used "parent with automatic weights" already because I can no longer do that when I select the bone and the character $\endgroup$
    – Othie
    Aug 30 at 16:16
1
$\begingroup$

It's the mesh. There are some issues and the overall topology is not ideal for animation.

Issues that prevent the Parent To > With Automatic Weights operation are:

  • duplicated vertices. In Edit mode, use M > Merge By Distance to get rid of them
  • overlaying/intersecting faces in the head. Select a face at the ear and hide it with H (Use Alt+H to unhide). Peek in the head and you will see there are faces inside. Delete them all (X)

Topology

The arms and legs have too few edge loops. Add more so they can bend properly. At the sides, there are too many edges. Use X > Dissolve Edge to remove them.

Have a look at this related question: My Model's Forearm Twists Too Much

$\endgroup$
1
  • 1
    $\begingroup$ This worked for me! Thanks a lot! $\endgroup$
    – Othie
    Aug 31 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.