0
$\begingroup$

Good day, I started making a model in blender and I have made my first rig but for some reason when I select my mesh and my rig and hit ctrl + p I do not have the option to armature deform with automatic weights but I went to the object tab and pressed it but it did not produce any results as I can move my rig but my mesh does not move with it. Can anyone help me with this problem? Attached below is my blender file.

The goal that I am looking for is to be able to move my created mesh with the rig. Edit: I have finally made my model to move but the shirt keeps on disappearing is there anyway to fix this?

$\endgroup$
4
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Aug 28 at 3:05
  • $\begingroup$ What do you mean by "when I select my armature AND my RIG..."? Your armature IS your rig. You should be selecting your MESH, and then select your ARMATURE, and then hit CTRL+P. $\endgroup$
    – R-800
    Aug 28 at 3:05
  • $\begingroup$ clicking on your link produces "empty directory" error messages. To add a blend file to your question: Grab the URL of the question. Go to blend-exchange.com. Select the blend file. Add the url of the question. Grab the url that results. Go back to the question and edit it. Add the new url to the bottom of the post. $\endgroup$ Aug 28 at 3:07
  • $\begingroup$ Thank you for your comments edited the question, I am sorry that I am still unfamiliar with the terms in blender but when i press CTRL + P i do not have the option to deform with automatic weights my mesh and my rig. $\endgroup$
    – Paolo Chua
    Aug 28 at 3:11
2
$\begingroup$

Your Armature modifier should have choosen Object > Armature (not a mesh object) ...

enter image description here

You can set it manually in modifier, but it would be faster to ...

  • Delete your Armature modifiers
  • Select Mesh object with Shift Armature object
  • Parent Ctrl+P With Automatic Weight

it will assign and set modifier correctly and automaticly. If you get Loop error message clear parent first Alt+P

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.