5
$\begingroup$

I made 3 planes on EEVEE and gave them a separate RGB materials each: Material for RED One for red, one for blue, one for green.

I tried both Alpha Blend and Alpha Hashed blend mode: blend mode

I also made my colour space to standard.

how do I make the combination of the 3 to be as white as possible, not like grey. my output is not pure white

I tried to increase my exposure to achieve my desired result: enter image description here enter image description here

But, is this the right way of doing it? I know people here have a lot of creative ways of doing things in Blender, I'm curious what one can do to achieve this that doesn't require changing the exposure.

EDIT:

Thanks, Rich Sedman; your solution is the proper solution. I don't know why I forgot about the Add Shader, quite embarrassing.

I'm able to pull down the emission and exposure to one which is what I'm after.

Rich Sedman's solution

$\endgroup$

2 Answers 2

12
$\begingroup$

In this situation you should be using an Add Shader rather than a Mix Shader - since you're expecting 100% transparency from each of the overlapping planes.

An emission surface is actually 100% opaque (if you set the strength to zero you'll just get a black surface, not transparent). In your case you're making each plane effectively 50% opaque so it is blocking the light from behind. By using the Add shader you're taking the Emmision properties and adding it to the light that is coming through from behind the surface using the full transparency.

$\endgroup$
0
$\begingroup$

What does it look like boosting the emission strength on the material while leaving exposure as default?

Also principled shader makes iterating much faster esp. with transparency; set base color to #000000 and it won't affect the lighting output, lets you control alpha and emission strength separately (rather than sequentially combined like in the screen shot material)

$\endgroup$
1
  • 1
    $\begingroup$ That was my first thought, that's why there's an emission node there, but the more I add on emission, the more it bleeds through the basic colours with bloom enabled 🤔 I kinda wanted to have the bloom enabled just enough to make a slight glow outside, but not too much to cause discolouration inside the 3 planes. I'm kinda just curious what other solution the wizards here can come up 🤣 $\endgroup$
    – Sophia
    Aug 28, 2021 at 2:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .