0
$\begingroup$

I'm applying a texture based on this video; it works well. The textured grid and its wireframe is shown: enter image description here This is fine. I'd like to do a little sculpting on the grid. The simplest way to show the problem that arises is to just enter the Sculpting screen, activate Dyntopo and smooth shading, then go back to layout and render again - without doing any actual sculpting. This triangulates the grid and when rendered the triangulation is visible (note: scale of render and wireframe is slightly different, but rendered triangles match wireframe subdivision): enter image description here I've tried a variety of clean up: everything available in the Edit->Mesh menu, especially things related to normals; tris to quads; removing and replacing the texture on the grid; rebuilding and reapplying the texture node by node; changing the angle of view and the angle of the grid; tweaking the texture settings. Nothing I've tried gets rid of this pattern.

Note: this is a completely procedural pattern, no images are involved; the node tree is shown below. Also, this is the simplest example I could concoct; actually sculpting something produces the same problem. There is also a subdivision surface modifier applied, and "Displacement and Bump" is selected.

Any thoughts on how to fix this?

enter image description here

$\endgroup$
2
  • $\begingroup$ If you want quads, you'd have to turn off dyntopo. "Dyntopo is a live tesselation depending on brush settings for topology." from blender.stackexchange.com/a/135841/31447, manual link: docs.blender.org/manual/en/latest/sculpt_paint/sculpting/… $\endgroup$
    – brockmann
    Aug 27 at 13:41
  • $\begingroup$ I don't specifically want quads; I ran tris to quads in an effort to fix this problem. Note that the problem remains whether left as triangles or converted to quads. The example shown hasn't been converted to quads, although doing so doesn't produce any change to the triangular patterning shown. $\endgroup$
    – SixDegrees
    Aug 27 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.