0
$\begingroup$

This is my character modelenter image description here

And the right arms do stick to the body but not the left arm. Can anyone help with this? enter image description here

Also the legs except for the shoe do not seem to move. I really wanted to know how to make them move properly. enter image description here

Are there stuff I can do to fix this? Rig Link: https://www.mediafire.com/file/1n2xnoc9ifkocx8/jujurighelp.blend/file

$\endgroup$
0

1 Answer 1

2
$\begingroup$

There a few things you need to fix:

1) To have the arms and legs bend in the right direction you need to adjust the metarig and make the elbows bend a tiny bit backward and the knee forward: elbow fixTop view on the metarig to fix the elbows

Then update the rig with Generate Rig. Make sure the rig armature is visible when you press the button.

2) The arm doesn't move because you probably got the Heat Weighting: Failed to find solution for one or more bones error. This is because the arm (named Hand) has loose vertices. Remove them and the With Automatic Weights operation will work.

  • the parts are tiny. But with L you can select the loose mesh parts. Delete the hidden, broken sphere. Select all parts and hide them H. Then invert the selection with Ctrl+I and you have the bad parts selected:
    arm meshArm with loose mesh snippets

3) The arms and legs need more edge loops else they cannot bend properly. Add some loops and parent the mesh to the rig again With Automatic Weights:

more loops

Before (only 1 loop):
leg bad

After (more loops):
leg good

4) The weights of the hair and eyes need to be fixed after Automatic Weights (it's not perfect) because the hair will move with the hands and the eyes stick into the head. A quick way to do this is to assign them only to the head bone which it DEF-spine.006

  • select the Hair, look for the vertex group DEF-spine.006 which gives the bone influence to the mesh. We keep only this group and delete all other groups.
  • lock this group with the "lock icon", then select Delete All Unlocked Groups from the menu to get rid of all unwanted bone influences.
  • unlock the group again
  • just to be sure the bone has full weight to all vertices of the mesh switch to Edit mode, select everything A, and press the Assign button in the Vertex Groups section to assign the hair mesh to the DEF-spine.006 group.

Repeat the steps for the eyes!

vertex groups

5) Lower the levels of the Subdivision Surface modifier to 1 & 2 or 2 & 2. Right now, it's 4 for the viewport and only 2 for the render. Better go with a low value and enable the Shade Shooth option.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .