enter image description here

In eevee render the edges of my textures are getting really blurry. I've tried both closest and linear interpolation and both look horrible. However if I switch to cycles it looks like I'd expect so I don't think the issue is with my texture. Is there an eevee setting or something I'm missing to make the color transition less blurry.

My texture resolution is 2048 and the texture has a very hard edge going from blue to while in a single pixel.

Blend file

  • $\begingroup$ It's looks like a double geometry in your scene. Are you sure that you haven't 2 objects on same spot, or try M⇾ by distance to remove double vertexes. $\endgroup$
    – Crantisz
    Aug 26, 2021 at 17:29
  • $\begingroup$ Unfortunately that does not appear to be the case. Select all m distance returns with 0 vertexes removed. Clicking on a a vertex and moving it also doesn't show any overlapping vertexes. I also did / to make sure there were not other overlapping objects and that didn't solve the issue either. $\endgroup$ Aug 26, 2021 at 17:46
  • $\begingroup$ Can you share the plane, then blend-exchange.com ? $\endgroup$
    – Crantisz
    Aug 26, 2021 at 17:49
  • $\begingroup$ Sure thing. I uploaded the file and added it to the question. $\endgroup$ Aug 26, 2021 at 17:59

1 Answer 1


I have inspected your file and I think it is mip-map issue. Real-time renderers like EEVEE creates low-res versions of textures to save memory and increase performance

First, check if you have some limits in preferences:

enter image description here

If it is not, I think openGL can use mip-maps to save video memory. If it so, I believe this will not appear on finial render, check this.

  • $\begingroup$ This fixed it. Thank you so much this was driving me insane! $\endgroup$ Aug 26, 2021 at 19:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .