2
$\begingroup$

I am currently working in Blender in Eevee and getting a really weird glitch where I can see random faces of my object in front of the faces I should be seeing. For example, in the image below, I can see the inside of the box although it has a front which I should be able to see instead. This face now appears at the back of the object?

enter image description here

The image above is how it looks in Eevee's LookDev, Renderer and Cycles LookDev mode. The only one it is correct in is Cycle's Render although the colour is really washed out. This was made using 'Images as Planes' addon.

enter image description here

Thanks in Advance!

$\endgroup$
2
  • $\begingroup$ Is backface culling off, maybe your normals are facing wrong way, turn on face orientation and check it? Also yes it is washed out(or white) maybe because your background color is too strong? Because there are softened shadows I assume that you are using white color background with strenght 1 or higher and it lighten your object $\endgroup$
    – MikoCG
    Aug 26, 2021 at 9:06
  • $\begingroup$ Hi, Thanks for your quick reply! In viewport shading I have backface culling turned off, no idea how to check in the other views. Think my normals are all okay, blue faces are all facing outwards, think that's right? Finally, I'm using a HDRI to light it so I'll try turn that down a little and see if that works, still unsure of the view glitch however ... $\endgroup$ Aug 26, 2021 at 9:16

1 Answer 1

5
$\begingroup$

The problem that you have faced known as sorting problem:

https://docs.blender.org/manual/en/dev/render/eevee/materials/settings.html#sorting-problem

I believe you have exported images using Import images as planes, that sets transparent mode to Alpha Blend by default. When you are using alpha blend, it sorts objects based on object centers (origins), but not on meshes.

How to fix that?

  • Moving origins to geometry from context menu may help, but not in 100% cases.

enter image description here

  • Change transparent mode to Alpha clip or Opaque (note, Opaque disables transparent, Alpha clip makes transparent sharp). I think if you don't need transparent at all, you should disable it using this way.

enter image description here

  • Alpha Hashed works better of all, but it is noisy.
$\endgroup$
1
  • $\begingroup$ Hi Crantisz! This has worked perfectly, the transparency was set to 'Alpha Blend' and when changed to 'Opaque' ... BOOM. All fixed! Really appreciate your help and speedy reply! Love the Blender Community :) Thank you! $\endgroup$ Aug 26, 2021 at 10:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.