0
$\begingroup$

I'm making a model of a building, and I need to have my building look like this:

enter image description here When I make all the shapes and piece them together, it makes for very weird shading(each face has weird shading) :

enter image description here

Does anyone know how to correct the shading?

$\endgroup$
8
  • 1
    $\begingroup$ Loop cuts into a plane. $\endgroup$
    – Ron Jensen
    Commented Aug 25, 2021 at 2:33
  • $\begingroup$ if you mean that you'll need to extrude each face, you must create a series of horizontal and vertical edge loops on your cube object in order to draw the windows $\endgroup$
    – moonboots
    Commented Aug 25, 2021 at 6:43
  • $\begingroup$ Blender doesn't allow for a face to have a hole in it. If you want a flat surface with a hole, you have to split the face by connecting an edge to the hole edges. How exactly you split it is up to you and a matter of how 'clean' you want your topology to be. I'd just cut loop cuts around the hole bulding, vertically and horizontally, aligning the loops with the windows so you end up with nice rectangular quads, then you can just extrude the windows. Another way is creating cubes the sizes of the windows and using boolean to cut them out, but you might have to fix topology afterwords anyway. $\endgroup$ Commented Aug 25, 2021 at 13:39
  • $\begingroup$ I've tried loop cuts, but It makes multiple shapes, not one big shape. It sounds like I have less of a shape problem, and more of a shading problem, as seen in my screenshots below. $\endgroup$ Commented Aug 25, 2021 at 19:43
  • $\begingroup$ Is it possible that my flat shading has something to do with it, do I need to make it smooth shading? $\endgroup$ Commented Sep 13, 2021 at 0:08

2 Answers 2

2
$\begingroup$

I think I came up with a solution. For some reason, now I can't really show any before/after pictures because I'm unable to replicate what was there before. But here is my building in edit-mode: enter image description here

Before, each face would shade in a weird way, which I tried to show in the pictures above. So If I remember correctly, I ended up setting all the faces on the front (not including windows), to smooth. Then I used auto-smooth, which is found here:

enter image description here

As you can see it is not currently in use. This actually confused me, because it should have been in use. But for a lot of the projects I use auto-smooth on, it kinda bugs out and says that I'm either using it or not using it, and whether it's on or off doesn't matter. At this point I'm kind of confused about auto-smooth, but it worked, and now the whole thing is in flatly shaded, and looking just fine, but when I turn on auto-shading, the whole thing reverts back to it's original messy shading. So IDK what going on there. Hope this response helps (despite my confusion about the auto-shader).

$\endgroup$
1
  • $\begingroup$ This is a very good answer for one that answers your own question-- a model of how to do it! Thank you for taking the time to demonstrate how to solve your original problem. As for autosmooth, I think it's named poorly: it's really auto sharpen, because what it does is mark edges as sharp if the angle between those edges' faces is greater than the angle specified. Otherwise, you're going to get smooth shading on your sharp angles, which is almost never going to look good on these kind of 90 degree angles. In your case, using flat shading would probably also have worked. $\endgroup$
    – Nathan
    Commented Jan 7, 2022 at 0:03
1
$\begingroup$

This is a question of topology. It's hard for Blender to handle a face with a lot of holes (the windows). A more suitable approach would be to connect each window one after one with (if possible) regular rectangle. There could also be trapeze, but not to compressed. You could also put some triangles there or there if it's too hard to keep everything quadrangular.

If you have a problem of shading, it's because normals of your faces are sometimes inversed. To fix this, you sould select everything (ctrl+A), and then with alt+N, you will access to various options about normals. You can choose Recalculte Outside for instance.

$\endgroup$
2
  • $\begingroup$ I did that and got this: BlenderScreenshot1 BlenderScreenshot2 The Normals are all on the outside, but the shading still acts weird. $\endgroup$ Commented Aug 25, 2021 at 19:19
  • $\begingroup$ I should note that this is with flat shading, not smooth shading (except the left side which for some reason decided to shade smoothly, I changed it back to flat) $\endgroup$ Commented Aug 25, 2021 at 19:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .