1
$\begingroup$

my problem is the following: I've made an object in blender and now I've begun applying material but I've noticed that I've added multiple meshes between the innermost and the outermost. This is quite annoying for the part which should have a glass material (the "vizor" as it is visible in the captures). In fact I've first tried to select face without limit selection to visible but as there is the back of the object which is also selected this have not really worked.

EDIT: Ok I'll try to clarify my issue, I've uploaded another capture, this time only one half of the mesh. As you can see there is multiple inner faces especially in the red rectangle (in the image attached) and those inner faces are those I want to assign material on (or delete all other than to outermost)

mesh cut in half

$\endgroup$
  • 1
    $\begingroup$ So, what is it you do not know? How to select only those faces that are obscured or how to assign a material to only selected faces? $\endgroup$ – user7952 Jan 21 '15 at 17:11
  • $\begingroup$ @SixthOfFour I just want to select those faces only (then it is easy to apply material), I know the fact you can disable the property "select only visible faces" (or using wireframe) but in this special case there are some faces on the back of the mesh (right on the pic) which will be selected at the same time $\endgroup$ – Camille Gallet Jan 21 '15 at 20:05
  • $\begingroup$ Are those faces connected to the rest of the object, i.e. are there any edges between the parts? If not, you can try selected one face/edge/vertex and pressing Ctrl L (Select linked). It would be easier to help if you shared your .blend so someone could see exactly how everything connects. $\endgroup$ – user7952 Jan 21 '15 at 20:12
  • $\begingroup$ Thanks for your answer @SixthOfFour, I've uploaded the mesh here drive.google.com/file/d/0B19X6LROOyg_YU5ENHEyUU1WbHc/… $\endgroup$ – Camille Gallet Jan 21 '15 at 20:20
1
$\begingroup$

I went with the delete all but the outermost option (well, I kept two layers of the four you had). You have a circular opening in the top of the inside of the helmet. Select all the faces of its rim. I used circle (C) select for this and panned around until all were selected.
enter image description here

Delete these faces (X then F)
enter image description here

Select one face on the unwanted geometry
enter image description here

Select linked (CtrlL)
enter image description here

Delete everything that's selected (X then F)
enter image description here

It now looks like this (with all selected, zoomed out and limit selection to visible disabled)
enter image description here

I hope this helps.

$\endgroup$
  • $\begingroup$ Glad I could help. And a further note: The shading artifacts are caused by several faces that aren't completely flat and by the fact that most of the faces are triangles. Both of those cause strange angles between faces, which make the light bounce in the "wrong" direction. Most of it is on the inside, so you'll be able to get away with it in this case, unless you need to show the inside. But as a rule of thumb, use quads whenever possible, triangles when there's no other way and n-gons ONLY if you either want the artifacts they cause or you can make them completely flat. $\endgroup$ – user7952 Jan 22 '15 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.