I am very new to blender and working on my first model: a bed. I'm trying to model it with real world measurements, but I'm having a really hard time.

I'm using Blender 2.93a and have a scaled cube for the mattress and one for the base of the bed. The edge length for the height of the mattress is 30cm and while the height of the base is visibly around twice the mattress' height, its measurements are still the same or less.

screenshot of a corner of the bed where one height edge says 30cm and another that is clearly 2 times the size says 30.2cm

screenshot of a corner of the bed where one height edge says 30cm and another that is clearly 2 times the size says 28.4cm

I scaled the larger edge below 30cm to be sure and it's still longer than the 30cm edge.

What could be causing these inconsistencies and how do I fix it? Also can I input exactly what dimensions I want for edges or for a whole cuboid?

  • 3
    $\begingroup$ This could be the result of non-uniform scale - it happens when you scale in Object Mode instead of Edit Mode. To fix it, select the object in Object Mode and press Ctrl+A (apply) and select scale. $\endgroup$ Commented Aug 21, 2021 at 2:40
  • $\begingroup$ Maybe have a look here $\endgroup$
    – Robin Betts
    Commented Aug 21, 2021 at 13:58

1 Answer 1


TL;DNR: Scale operations in object mode remember the scale but don't actually apply it. You need a separate apply step.

Here is a simple example to explain what people are telling you in the comments

  • Add a cube
  • In Edit mode enable edge length in overlays menu.

top panel showing edge length

  • In Object mode scale the cube to 1/10 of its size along the Z axis (shortcut SZ.1ENTER)
  • In Object mode the side panel will show that you've scaled Z and that it's now 0.2 m as you'd expect:

side panel showing scale and length

  • In Edit mode, the edge length measurements will show the original size:

edge measurements

That is because scaling in object mode doesn't apply the scale change but only remembers it and uses it to draw. To fix your measurements

  • In Object mode apply the scale (shortcut CTRLS) and select Scale from the apply menu:

apply menu showing scale

  • Now the Object mode side panel will show the same length for Z but the Z scale will be 1:

dimensions and scale when scale is applied

  • and the Edit mode measurements will show the same thing:

edit mode measurements now match object mode

  • $\begingroup$ Woof. Thanks for this $\endgroup$ Commented Mar 25, 2022 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .